aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-08 20:17:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:15:59 -0800
commitf42195493b85fbd9bdc1ae0089084669c8cd558d (patch)
treedf18ccccbdb050a927395f27b642562cb97127bf /meta/recipes-support
parent856a70cf6ca9137d5c07c2aa9ef447032589504d (diff)
downloadopenembedded-core-contrib-f42195493b85fbd9bdc1ae0089084669c8cd558d.tar.gz
shared-mime-info: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch14
-rw-r--r--meta/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch12
2 files changed, 14 insertions, 12 deletions
diff --git a/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch b/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
index 3c9f1ea438..262ff7562c 100644
--- a/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
+++ b/meta/recipes-support/shared-mime-info/shared-mime-info/install-data-hook.patch
@@ -8,16 +8,18 @@ Upstream-Status: Pending
Signed-off-by: Joe Slater <jslater@windriver.com>
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -44,7 +44,9 @@ $(pkgconfig_DATA): config.status
- @INTLTOOL_XML_RULE@
- @INTLTOOL_DESKTOP_RULE@
+Index: shared-mime-info-1.9/Makefile.am
+===================================================================
+--- shared-mime-info-1.9.orig/Makefile.am
++++ shared-mime-info-1.9/Makefile.am
+@@ -50,7 +50,9 @@ else
+ update_mime_database="$(top_builddir)/update-mime-database$(EXEEXT)"
+ endif
-install-data-hook: install-binPROGRAMS
+# do NOT make this dependent on anything!
+#
+install-data-hook:
if ENABLE_UPDATE_MIMEDB
- $(DESTDIR)"$(bindir)/update-mime-database" -V "$(DESTDIR)$(datadir)/mime"
+ $(update_mime_database) -V "$(DESTDIR)$(datadir)/mime"
endif
diff --git a/meta/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch b/meta/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
index 84c4d03731..fea34a55a2 100644
--- a/meta/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
+++ b/meta/recipes-support/shared-mime-info/shared-mime-info/parallelmake.patch
@@ -11,17 +11,17 @@ RP 10/10/2011
Upstream-Status: Pending
Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
-Index: shared-mime-info-1.0/Makefile.am
+Index: shared-mime-info-1.9/Makefile.am
===================================================================
---- shared-mime-info-1.0.orig/Makefile.am
-+++ shared-mime-info-1.0/Makefile.am
+--- shared-mime-info-1.9.orig/Makefile.am
++++ shared-mime-info-1.9/Makefile.am
@@ -1,5 +1,3 @@
-SUBDIRS=. po
-
AM_CPPFLAGS = $(ALL_CFLAGS)
packagesdir = $(datadir)/mime/packages
-@@ -72,8 +70,7 @@ uninstall-hook:
+@@ -81,8 +79,7 @@ endif
all: $(defaultmakedeps)
@@ -29,5 +29,5 @@ Index: shared-mime-info-1.0/Makefile.am
- $(AM_V_GEN) $(MAKE) -C po shared-mime-info.pot
+create-pot: po
- check: create-pot freedesktop.org.xml update-mime-database check-translations
- if test -e $(top_builddir)/freedesktop.org.xml; then \
+ local-test: create-pot freedesktop.org.xml update-mime-database$(EXEEXT)
+ if CROSS_COMPILING