aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-15 16:40:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-07 06:33:59 -0800
commiteb7632f593b81066da4de44bc001974d6726a118 (patch)
tree058573bc17189761d1fd99ed895dd963279a56f2 /meta/recipes-support
parent453a433768bff76e4d3ad9bf40fd9d8210b0950e (diff)
downloadopenembedded-core-contrib-eb7632f593b81066da4de44bc001974d6726a118.tar.gz
libpcre: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libpcre/libpcre2/pcre-cross.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta/recipes-support/libpcre/libpcre2/pcre-cross.patch b/meta/recipes-support/libpcre/libpcre2/pcre-cross.patch
index 9516caf51a..871cdfcb7d 100644
--- a/meta/recipes-support/libpcre/libpcre2/pcre-cross.patch
+++ b/meta/recipes-support/libpcre/libpcre2/pcre-cross.patch
@@ -9,11 +9,11 @@ Upstream-Status: Pending
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-diff --git a/Makefile.am b/Makefile.am
-index 38f1d41..2bde083 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -298,9 +298,21 @@ bin_SCRIPTS = pcre2-config
+Index: pcre2-10.30/Makefile.am
+===================================================================
+--- pcre2-10.30.orig/Makefile.am
++++ pcre2-10.30/Makefile.am
+@@ -325,9 +325,21 @@ bin_SCRIPTS = pcre2-config
## to copy a distributed set of tables that are defined for ASCII code. In this
## case, dftables is not needed.
@@ -35,13 +35,13 @@ index 38f1d41..2bde083 100644
src/pcre2_chartables.c: dftables$(EXEEXT)
rm -f $@
./dftables$(EXEEXT) $@
-diff --git a/configure.ac b/configure.ac
-index d7c57aa..d6eb0aa 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -59,6 +59,23 @@ then
- fi
- fi
+Index: pcre2-10.30/configure.ac
+===================================================================
+--- pcre2-10.30.orig/configure.ac
++++ pcre2-10.30/configure.ac
+@@ -60,6 +60,23 @@ fi
+ # This is a new thing required to stop a warning from automake 1.12
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+if test x"$cross_compiling" = xyes; then
+ CC_FOR_BUILD="${CC_FOR_BUILD-gcc}"