summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJoerg Vehlow <joerg.vehlow@aox.de>2022-05-25 11:26:59 +0200
committerSteve Sakoman <steve@sakoman.com>2022-05-31 05:49:55 -1000
commitb34aaa9acbe865f61be0a598b8df2735b1bc76cd (patch)
treef71d5c4a86d6c071c8b649e3ab8ca7f06851432f /meta/recipes-support
parentbd72b15e9a4c9bb4f155d19c84bcf20d788bd568 (diff)
downloadopenembedded-core-contrib-b34aaa9acbe865f61be0a598b8df2735b1bc76cd.tar.gz
libseccomp: Add missing files for ptests
pfc files are used e.g. in 38-basic-pfc_coverage.sh valgrind_test.supp is required, when valgrind is installed, otherwise all valgrind tests fail Signed-off-by: Joerg Vehlow <joerg.vehlow@aox.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 32ba67bc37b5ca73f7d29cb6c7de281ab8f824bd) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libseccomp/libseccomp_2.5.3.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/libseccomp/libseccomp_2.5.3.bb b/meta/recipes-support/libseccomp/libseccomp_2.5.3.bb
index e6260a7754..d47200e01c 100644
--- a/meta/recipes-support/libseccomp/libseccomp_2.5.3.bb
+++ b/meta/recipes-support/libseccomp/libseccomp_2.5.3.bb
@@ -37,6 +37,10 @@ do_install_ptest() {
for file in $(find tests/*.tests -type f); do
install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
done
+ for file in $(find tests/*.pfc -type f); do
+ install -m 644 ${S}/${file} ${D}/${PTEST_PATH}/tests
+ done
+ install -m 644 ${S}/tests/valgrind_test.supp ${D}/${PTEST_PATH}/tests
for file in $(find tools/* -executable -type f); do
install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
done