aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-17 17:48:31 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:30:57 +0000
commit5e0f27bd0d00dd9aa597d98d0a7d5b4f5d726925 (patch)
tree3e44e8e42156405264c1e4bbd6368d8b95022dfe /meta/recipes-support
parent70674d4ee2a24971d1bab048906fa8d0d2ba2e75 (diff)
downloadopenembedded-core-contrib-5e0f27bd0d00dd9aa597d98d0a7d5b4f5d726925.tar.gz
db: fix race issue for libdb-6.0.la
Fixed: libtool: link: `os_map.lo' is not a valid libtool object Makefile:867: recipe for target 'libdb-6.0.la' failed Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/db/db/Makefile-let-libdb-6.0.la-depend-os_map.l.patch32
-rw-r--r--meta/recipes-support/db/db_6.0.30.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db/Makefile-let-libdb-6.0.la-depend-os_map.l.patch b/meta/recipes-support/db/db/Makefile-let-libdb-6.0.la-depend-os_map.l.patch
new file mode 100644
index 0000000000..d4c6bb8e05
--- /dev/null
+++ b/meta/recipes-support/db/db/Makefile-let-libdb-6.0.la-depend-os_map.l.patch
@@ -0,0 +1,32 @@
+From 2902dda6e3f7b2cd5796a96af20deece610e2eb9 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Mon, 16 Nov 2015 22:20:49 -0800
+Subject: [PATCH] build_unix/Makefile: let libdb-6.0.la depend os_map.lo
+
+Fixed parallel issue:
+libtool: link: `os_map.lo' is not a valid libtool object
+Makefile:867: recipe for target 'libdb-6.0.la' failed
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ dist/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dist/Makefile.in b/dist/Makefile.in
+index 0a42375..d9e05b9 100644
+--- a/dist/Makefile.in
++++ b/dist/Makefile.in
+@@ -863,7 +863,7 @@ $(libdb_version): $(C_OBJS)
+ $(LN) -s $(libdb_version) $(libdb)
+
+ # Shared C library.
+-$(libso_target): $(C_OBJS) bt_rec@o@
++$(libso_target): $(C_OBJS) bt_rec@o@ os_map@o@
+ $(SOLINK) $(SOFLAGS) $(LDFLAGS) -o $@ $(C_OBJS) \
+ $(LIBCSO_LIBS)
+ $(RM) $(libdb)
+--
+1.7.9.5
+
diff --git a/meta/recipes-support/db/db_6.0.30.bb b/meta/recipes-support/db/db_6.0.30.bb
index d49df62b9a..ccdb6bd302 100644
--- a/meta/recipes-support/db/db_6.0.30.bb
+++ b/meta/recipes-support/db/db_6.0.30.bb
@@ -21,6 +21,7 @@ SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
SRC_URI += "file://arm-thumb-mutex_db5.patch;patchdir=.. \
file://fix-parallel-build.patch \
file://Makefile-let-libso_target-depend-on-bt_rec.patch \
+ file://Makefile-let-libdb-6.0.la-depend-os_map.l.patch;patchdir=.. \
"
SRC_URI[md5sum] = "ad28eb86ad3203b5422844db179c585b"