aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-08-01 17:14:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-01 23:03:14 +0100
commit1e96a8460b93ba9c0c9a6c4ea4ffd6a19302831c (patch)
tree3f3d18c040974ee519ad9497dcc9dce6286b0fbd /meta/recipes-support
parent72d673bef385e756bd858f9eca7fe419efaceb39 (diff)
downloadopenembedded-core-contrib-1e96a8460b93ba9c0c9a6c4ea4ffd6a19302831c.tar.gz
createrepo 0.4.11: create wrapper for python script
The native python is installed to ${STAGING_BINDIR_NATIVE}/python-native/python, so we should use wrapper for the python script. [YOCTO #2822] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/createrepo/createrepo_0.4.11.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta/recipes-support/createrepo/createrepo_0.4.11.bb b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
index dcddcf8331..42c7214bb2 100644
--- a/meta/recipes-support/createrepo/createrepo_0.4.11.bb
+++ b/meta/recipes-support/createrepo/createrepo_0.4.11.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
RDEPENDS_${PN}_virtclass-native += "libxml2-native rpm-native"
-PR = "r5"
+PR = "r6"
SRC_URI= "http://createrepo.baseurl.org/download/${BP}.tar.gz \
file://fix-native-install.patch \
@@ -24,3 +24,16 @@ do_install () {
oe_runmake -e 'DESTDIR=${D}' install
install -m 0755 ${WORKDIR}/rpm-createsolvedb.py ${D}${bindir}/
}
+
+# Wrap the python script since the native python is
+# ${bindir}/python-native/python, and the "#! /usr/bin/env python" can't
+# find it since it is not in PATH.
+do_install_append_virtclass-native () {
+ # Not all the python scripts should be wrapped since some of
+ # them are modules (be imported).
+ for i in ${D}${datadir}/createrepo/genpkgmetadata.py \
+ ${D}${datadir}/createrepo/modifyrepo.py \
+ ${D}${bindir}/rpm-createsolvedb.py ; do
+ create_wrapper $i ${STAGING_BINDIR_NATIVE}/python-native/python
+ done
+}