summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2020-08-18 17:59:02 +0800
committerSteve Sakoman <steve@sakoman.com>2020-09-01 05:45:54 -1000
commit82df23b088a4844d1f171bfa70c212ff62c3a741 (patch)
treec536bc93bab60ca4babee893560d3c96a0ce26a3 /meta/recipes-support
parent156d3e066dbac0986f4f55bef9b2d9922b18e738 (diff)
downloadopenembedded-core-contrib-82df23b088a4844d1f171bfa70c212ff62c3a741.tar.gz
gpgme: fix multilib header conflict
fix error: file /usr/include/gpgme.h conflicts between attempted installs of gpgme-dev-1.13.1-r0.core2_64 and lib32-gpgme-dev-1.13.1-r0.core2_32 part of diff: -#if 64 +#if 0 #ifndef _FILE_OFFSET_BITS -#error GPGME was compiled with _FILE_OFFSET_BITS = 64, please see the section "Largefile support (LFS)" in the GPGME manual. +#error GPGME was compiled with _FILE_OFFSET_BITS = 0, please see the section "Largefile support (LFS)" in the GPGME manual. #else -#if (_FILE_OFFSET_BITS) != (64) -#error GPGME was compiled with a different value for _FILE_OFFSET_BITS, namely 64, please see the section "Largefile support (LFS)" in the GPGME manual. +#if (_FILE_OFFSET_BITS) != (0) +#error GPGME was compiled with a different value for _FILE_OFFSET_BITS, namely 0, please see the section "Largefile support (LFS)" in the GPGME manual. #endif #endif #endif LFS support is enabled by default, and this header is generated during build according to current configure Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit bd056f9c4c22740a4f7ede00c758a21037eae5ca) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.13.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.13.1.bb b/meta/recipes-support/gpgme/gpgme_1.13.1.bb
index 9fc1ae24a4..b51534351d 100644
--- a/meta/recipes-support/gpgme/gpgme_1.13.1.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.13.1.bb
@@ -59,7 +59,7 @@ EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \
--disable-lang-python-test \
'
-inherit autotools texinfo binconfig-disabled pkgconfig distutils-common-base ${PYTHON_INHERIT}
+inherit autotools texinfo binconfig-disabled pkgconfig distutils-common-base ${PYTHON_INHERIT} multilib_header
export PKG_CONFIG='pkg-config'
@@ -83,3 +83,7 @@ do_configure_prepend () {
rm -f ${S}/m4/libassuan.m4
rm -f ${S}/m4/python.m4
}
+
+do_install_append() {
+ oe_multilib_header gpgme.h
+}