summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-05-08 18:30:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-13 15:42:24 +0100
commit856ffc7d0893c1dc549baf401899947f70d31896 (patch)
treea499d1521788209ced2199a2b24eb138424cf3fd /meta/recipes-support
parent43104b547cb79693c83df0882773ae8dd74b1d35 (diff)
downloadopenembedded-core-contrib-856ffc7d0893c1dc549baf401899947f70d31896.tar.gz
lrzsz connman-gnome libfm: ignore various issues fatal with gcc-14
work arounds for: oe-core/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb:do_compile oe-core/meta/recipes-connectivity/connman/connman-gnome_0.7.bb:do_compile oe-core/meta/recipes-support/libfm/libfm_1.3.2.bb:do_compile http://errors.yoctoproject.org/Errors/Build/183127/ More fixes on ML (especially for -native with gcc-14 on host) cdrtools: https://lists.openembedded.org/g/openembedded-core/message/198899 syslinux: https://lists.openembedded.org/g/openembedded-core/message/198901 Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libfm/libfm_1.3.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/libfm/libfm_1.3.2.bb b/meta/recipes-support/libfm/libfm_1.3.2.bb
index 057c737029..1d7609165b 100644
--- a/meta/recipes-support/libfm/libfm_1.3.2.bb
+++ b/meta/recipes-support/libfm/libfm_1.3.2.bb
@@ -53,3 +53,7 @@ do_install:append () {
rm -f ${D}${libdir}/libfm-extra.a
rm -f ${D}${libdir}/libfm-extra.la
}
+
+# http://errors.yoctoproject.org/Errors/Details/766924/
+# libfm-1.3.2/src/actions/action.c:2050:25: error: assignment to 'gchar **' {aka 'char **'} from incompatible pointer type 'const gchar * const*' {aka 'const char * const*'} [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"