aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-12-22 16:13:56 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:39:11 +0000
commit32da05fa8ff6bd713fbf691bc549857aa0737553 (patch)
treeb949aa8cfd47ce94b98b091caf1becedd5710657 /meta/recipes-support
parentbe3c48f607cc5fca9ab98d5c4602155462c8b718 (diff)
downloadopenembedded-core-contrib-32da05fa8ff6bd713fbf691bc549857aa0737553.tar.gz
meta: use require instead of include when file should exist
If the file is expected to exist, then we should always be using require so that if it doesn't we get an error rather than some other more obscure failure later on. (From OE-Core rev: 603ae6eb487489e65da69c68e532cb767ccc1fc2) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.62.0.bb2
-rw-r--r--meta/recipes-support/boost/boost_1.62.0.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.62.0.bb b/meta/recipes-support/boost/bjam-native_1.62.0.bb
index 32646d707b..46013f343b 100644
--- a/meta/recipes-support/boost/bjam-native_1.62.0.bb
+++ b/meta/recipes-support/boost/bjam-native_1.62.0.bb
@@ -1,4 +1,4 @@
-include boost-${PV}.inc
+require boost-${PV}.inc
SUMMARY = "Portable Boost.Jam build tool for boost"
SECTION = "devel"
diff --git a/meta/recipes-support/boost/boost_1.62.0.bb b/meta/recipes-support/boost/boost_1.62.0.bb
index 120d12968b..cde03f2b8e 100644
--- a/meta/recipes-support/boost/boost_1.62.0.bb
+++ b/meta/recipes-support/boost/boost_1.62.0.bb
@@ -1,5 +1,5 @@
-include boost-${PV}.inc
-include boost.inc
+require boost-${PV}.inc
+require boost.inc
SRC_URI += "\
file://arm-intrinsics.patch \