aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-04-30 13:56:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-30 16:44:39 +0100
commitb8f82a8808b0d217815b30ed06efc8a0be4494a5 (patch)
treefea0d8df52f367fe7e8e6be4bde3cf55d3fe28f3 /meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb
parentcdbcadee68a47e985d25ba39359f3a3fa0049a8a (diff)
downloadopenembedded-core-contrib-b8f82a8808b0d217815b30ed06efc8a0be4494a5.tar.gz
sqlite3: restore upstream version numbering
Regardless of the numbering used in source archive filenames, the upstream version number is in dotted form in documentation, release notes and the website, so we need to be using that here since that is what people will expect to see. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb')
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb b/meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb
new file mode 100644
index 0000000000..938829780a
--- /dev/null
+++ b/meta/recipes-support/sqlite/sqlite3_3.8.4.3.bb
@@ -0,0 +1,21 @@
+require sqlite3.inc
+
+LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=65f0a57ca6928710b418c094b3570bb0"
+
+def sqlite_download_version(d):
+ pvsplit = d.getVar('PV', True).split('.')
+ return pvsplit[0] + ''.join([part.rjust(2,'0') for part in pvsplit[1:]])
+
+PE = "3"
+SQLITE_PV = "${@sqlite_download_version(d)}"
+SRC_URI = "http://www.sqlite.org/2014/sqlite-autoconf-${SQLITE_PV}.tar.gz"
+
+S = "${WORKDIR}/sqlite-autoconf-${SQLITE_PV}"
+
+SRC_URI[md5sum] = "0f5459cde43cb269e5120ecd2c671ced"
+SRC_URI[sha256sum] = "e0e995e23a324a5d6ae95d8a836240382a4d7475d09707fc469c8cafcbd48d65"
+
+# Provide column meta-data API
+BUILD_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA"
+TARGET_CFLAGS += "-DSQLITE_ENABLE_COLUMN_METADATA"
+