aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/rng-tools/rng-tools_5.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-02-15 20:07:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-16 11:15:49 +0000
commit11359e9d5db948cf981228abe0020ce20087eb26 (patch)
treea952b8dd95ae2cc1795cb3bd410db11ccc28fee4 /meta/recipes-support/rng-tools/rng-tools_5.bb
parenta25858982ae313a13be95692496e4983c7bd4251 (diff)
downloadopenembedded-core-contrib-11359e9d5db948cf981228abe0020ce20087eb26.tar.gz
rng-tools: fix the build with musl
musl doesn't provide argp, so we need argp-standalone, as we do for uclibc. Rather than passing in -largp via the recipe, patch the configure script to provide an argument for the libargp usage and check for it when needed, and use PACKAGECONFIG. The initial patch to check for libargp and use it if available came from Gentoo. The patches are kept separate despite the second modifying what the first does, in order to keep the history/origin clear. (From OE-Core rev: 94ecc846f9b33fcec039936643c49728eedfefb7) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/rng-tools/rng-tools_5.bb')
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_5.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools_5.bb b/meta/recipes-support/rng-tools/rng-tools_5.bb
index 67f53f2998..9a19d1cb42 100644
--- a/meta/recipes-support/rng-tools/rng-tools_5.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_5.bb
@@ -1,9 +1,10 @@
SUMMARY = "Random number generator daemon"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=0b6f033afe6db235e559456585dc8cdc"
-DEPENDS_append_libc-uclibc = " argp-standalone"
SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/gkernel/${BP}.tar.gz \
+ file://0001-If-the-libc-is-lacking-argp-use-libargp.patch \
+ file://0002-Add-argument-to-control-the-libargp-dependency.patch \
file://init \
file://default"
@@ -19,6 +20,11 @@ python () {
inherit autotools update-rc.d
+PACKAGECONFIG = ""
+PACKAGECONFIG_libc-musl = "libargp"
+PACKAGECONFIG_libc-uclibc = "libargp"
+PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
+
RDEPENDS_${PN} = "libgcrypt"
do_install_append() {