aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pth
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-support/pth
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadopenembedded-core-contrib-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/pth')
-rw-r--r--meta/recipes-support/pth/pth_2.0.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-support/pth/pth_2.0.7.bb b/meta/recipes-support/pth/pth_2.0.7.bb
new file mode 100644
index 0000000000..8ee3cd4cd1
--- /dev/null
+++ b/meta/recipes-support/pth/pth_2.0.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GNU Portable Threads"
+HOMEPAGE = "http://www.gnu.org/software/pth/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;beginline=12;endline=15;md5=a48af114a80c222cafd37f24370a77b1"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
+
+PARALLEL_MAKE=""
+
+inherit autotools binconfig
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} = "${libdir}/libpth.so.*"
+FILES_${PN}-dev += "${bindir}/pth-config"