summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
diff options
context:
space:
mode:
authorAnibal Limon <anibal.limon@linaro.org>2020-04-28 16:18:04 -0500
committerSteve Sakoman <steve@sakoman.com>2020-11-16 06:16:32 -1000
commitbd7de7dd0992e0d7a6cc322a54cf9e69b052acca (patch)
treeb013f4d0707d352f6eb9b61d64c7316a9aba20c3 /meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
parent31f00ec9c6ab5fe74f1ba59f79322497ef8f4dc7 (diff)
downloadopenembedded-core-contrib-bd7de7dd0992e0d7a6cc322a54cf9e69b052acca.tar.gz
ptest-runner: Bump to 2.4.0
Add support for un ptests in multiple directories, useful in multilib builds. Changes, 1e9a845 Add support to specify multiple folder for ptest-runner 287ba30 Makefile: Fix TEST_LDFLAGS gcc cmdline position [YOCTO #12604] Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1203ee86e3cf4d73f6ba513452717f1c4f78c501) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
new file mode 100644
index 0000000000..9e62c486ac
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "A C program to run all installed ptests"
+DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
+program which loops through all installed ptest test suites and \
+runs them in sequence."
+HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SRCREV = "1e9a84585909b970cc8850d3ea02a7215dcfa5a3"
+PV = "2.4.0+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
+"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${bindir}/ptest-runner"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+}