aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-11-04 14:39:14 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:24:52 +0000
commit7227ce313586503c0939d0c916464e623ad9c238 (patch)
tree48baf33d5589a7f4b6c666ba4bfd3b8b41cd229f /meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch
parente1dc714593d3773f27973b4c9cc09495fa00e013 (diff)
downloadopenembedded-core-contrib-7227ce313586503c0939d0c916464e623ad9c238.tar.gz
nspr: Update to 4.10.1
Move patch directory files to nspr Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch')
-rw-r--r--meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch b/meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch
new file mode 100644
index 0000000000..a6fa1ea607
--- /dev/null
+++ b/meta/recipes-support/nspr/nspr/fix-build-on-x86_64.patch
@@ -0,0 +1,51 @@
+Fix build failure on x86_64
+
+When the target_cpu is x86_64, we should assume that the pkg uses 64bit,
+only if USE_N32 is set, we can assume that the pkg uses 32bit. It used a
+opposite logic before.
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+
+Upstream-Status: Pending
+---
+ configure.in | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 39c96a3..99a03ac 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1778,24 +1778,24 @@ tools are selected during the Xcode/Developer Tools installation.])
+ PR_MD_ASFILES=os_Linux_ia64.s
+ ;;
+ x86_64)
+- if test -n "$USE_64"; then
+- PR_MD_ASFILES=os_Linux_x86_64.s
+- else
++ if test -n "$USE_N32"; then
+ AC_DEFINE(i386)
+ PR_MD_ASFILES=os_Linux_x86.s
+ CC="$CC -m32"
+ CXX="$CXX -m32"
++ else
++ PR_MD_ASFILES=os_Linux_x86_64.s
+ fi
+ ;;
+ ppc|powerpc)
+ PR_MD_ASFILES=os_Linux_ppc.s
+ ;;
+ powerpc64)
+- if test -n "$USE_64"; then
++ if test -n "$USE_N32"; then
++ PR_MD_ASFILES=os_Linux_ppc.s
++ else
+ CC="$CC -m64"
+ CXX="$CXX -m64"
+- else
+- PR_MD_ASFILES=os_Linux_ppc.s
+ fi
+ ;;
+ m68k)
+--
+1.7.1
+