summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzop/lzop_1.04.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-18 17:49:05 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-19 15:59:09 +0000
commite243edc0456858d26b21a5b643ea9c0ae143fa4b (patch)
treeed2b91ab59e95fa70df6680a8f1a40e4b26db081 /meta/recipes-support/lzop/lzop_1.04.bb
parentf3be4cdad8304958401b3c18efddfdc6c6f61a58 (diff)
downloadopenembedded-core-contrib-e243edc0456858d26b21a5b643ea9c0ae143fa4b.tar.gz
lzop: upgrade 1.03 -> 1.04
License checksum changed due to updated copyright year and cleanup. 3 patches for miniacc.h were incorporated upstream. Build-tested on qemu targets, including x32. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lzop/lzop_1.04.bb')
-rw-r--r--meta/recipes-support/lzop/lzop_1.04.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/lzop/lzop_1.04.bb b/meta/recipes-support/lzop/lzop_1.04.bb
new file mode 100644
index 0000000000..b50c230437
--- /dev/null
+++ b/meta/recipes-support/lzop/lzop_1.04.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Real-time file compressor"
+DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\
+It is based on the LZO data compression library and its main advantages over \n\
+gzip are much higher compression and decompression speed at the cost of some \n\
+compression ratio. The lzop compression utility was designed with the goals \n\
+of reliability, speed, portability and with reasonable drop-in compatibility \n\
+to gzip."
+DEPENDS += "lzo"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://src/lzop.c;beginline=5;endline=21;md5=23d767de7754eb24b9e900b025cf7fc8"
+
+SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \
+ file://acinclude.m4 \
+ "
+SRC_URI[md5sum] = "271eb10fde77a0a96b9cbf745e719ddf"
+SRC_URI[sha256sum] = "7e72b62a8a60aff5200a047eea0773a8fb205caf7acbe1774d95147f305a2f41"
+
+inherit autotools
+
+do_configure_prepend () {
+ install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4
+}
+
+BBCLASSEXTEND = "native nativesdk"