aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.8.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-18 17:49:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-19 15:59:09 +0000
commit9f67079b03239d7c46552070ad5c80d7d7f4c5bf (patch)
tree2c49d1fae96daf49828cb99f32385481a3b1a3f4 /meta/recipes-support/lz4/lz4_1.8.3.bb
parent520e8f5721aab90815186533038c2f9f834546d5 (diff)
downloadopenembedded-core-contrib-9f67079b03239d7c46552070ad5c80d7d7f4c5bf.tar.gz
lz4: upgrade 1.8.2 -> 1.8.3
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.8.3.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.8.3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.8.3.bb b/meta/recipes-support/lz4/lz4_1.8.3.bb
new file mode 100644
index 0000000000..125836f7bf
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.8.3.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Extremely Fast Compression algorithm"
+DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
+
+LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
+LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
+ file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
+ "
+
+PE = "1"
+
+SRCREV = "641b453d9db536ee020851bfcb1dc39f61006f0a"
+
+SRC_URI = "git://github.com/lz4/lz4.git \
+ file://run-ptest \
+ "
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+
+do_install() {
+ oe_runmake install
+}
+
+BBCLASSEXTEND = "native nativesdk"