aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt
diff options
context:
space:
mode:
authorPhil Blundell <pb@pbcl.net>2013-04-24 12:43:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-29 14:45:06 +0100
commit499bb2c6b369a021ace3059426470d3371c07fb1 (patch)
tree5e0e8908cb127a0447797900f7d0ce6833935d5f /meta/recipes-support/libxslt
parentd853d5b6d011088ca1078283a6c7bfd60f47e7a2 (diff)
downloadopenembedded-core-contrib-499bb2c6b369a021ace3059426470d3371c07fb1.tar.gz
libxslt: Avoid regenerating manpage during "make install"
The timestamps in libxslt-1.1.28.tar.gz (specifically) are rather hokey, making the source files for the documentation appear newer than the generated output: -rw-rw-r-- 500/500 16307 2012-11-21 07:22 libxslt-1.1.28/doc/xsltproc.xml -rw-rw-r-- 500/500 7082 2012-09-12 07:24 libxslt-1.1.28/doc/xsltproc2.html -rw-rw-r-- 500/500 9475 2012-09-04 15:26 libxslt-1.1.28/doc/xsltproc.html -rw-rw-r-- 500/500 8256 2012-11-21 06:03 libxslt-1.1.28/doc/xsltproc.1 This causes make to decide that xsltproc.1 needs to be regenerated during the installation process. However, this requires a native xsltproc binary which may not be available, leading to errors like: | make[2]: /usr/bin/xsltproc: Command not found | make[2]: [xsltproc.1] Error 127 (ignored) Adding DEPENDS_class-target = "libxslt-native", or installing xsltproc in the host environment, fixes the above but the documentation still doesn't build: | I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl | warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl" | error | xsltParseStylesheetFile : cannot parse http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl | compilation error: file ./xsltproc.xml line 10 element refentry | xsltParseStylesheetProcess : document is not a stylesheet And in any case, requiring libxslt-native would increase build time for no real benefit. So, let's just adjust the timestamp on the shipped copy of xsltproc.1 to make it appear newer than the source files. (From OE-Core rev: 12074bf5319c1086f86efd00f502c91fed344698) Signed-off-by: Phil Blundell <philb@gnu.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libxslt')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
index 3f89e78df6..ae2e6b18b1 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.28.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -21,6 +21,10 @@ inherit autotools pkgconfig binconfig lib_package
# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
do_configure_prepend () {
sed -i -e 's/ansidecl.h//' ${S}/configure.in
+
+ # The timestamps in the 1.1.28 tarball are messed up causing this file to
+ # appear out of date. Touch it so that we don't try to regenerate it.
+ touch ${S}/doc/xsltproc.1
}
EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
='n269' href='#n269'>269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570