summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.31.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-10-04 14:35:08 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-09 12:33:09 +0000
commite9d487de8b5c03108c8c25c0365d5bd6b48f03e9 (patch)
treeaf9ec2c49eaeb3898eeabc2093e00b5d352fe1ef /meta/recipes-support/libxslt/libxslt_1.1.31.bb
parent29b0955c33fd905a5c1115e0c1e00b914e739c53 (diff)
downloadopenembedded-core-contrib-e9d487de8b5c03108c8c25c0365d5bd6b48f03e9.tar.gz
libxslt: update to 1.1.31
Drop upstreamed patches, including pkg-config support patch, as upstream now does use pkg-config. configure.in is now configure.ac, adjust recipe accordingly. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.31.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.31.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.31.bb b/meta/recipes-support/libxslt/libxslt_1.1.31.bb
new file mode 100644
index 0000000000..77b8b768eb
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.31.bb
@@ -0,0 +1,49 @@
+SUMMARY = "GNOME XSLT library"
+HOMEPAGE = "http://xmlsoft.org/XSLT/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
+
+SECTION = "libs"
+DEPENDS = "libxml2"
+
+SRC_URI = "ftp://xmlsoft.org/libxslt/libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch \
+ "
+
+SRC_URI[md5sum] = "14e9842a70fda476065f2eefcbc29af0"
+SRC_URI[sha256sum] = "db25e96b6b801144277e67c05b10560ac09dfff82ccd53a154ce86e43622f3ab"
+
+UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
+
+S = "${WORKDIR}/libxslt-${PV}"
+
+BINCONFIG = "${bindir}/xslt-config"
+
+inherit autotools pkgconfig binconfig-disabled lib_package
+
+# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
+do_configure_prepend () {
+ sed -i -e 's/ansidecl.h//' ${S}/configure.ac
+
+ # The timestamps in the 1.1.28 tarball are messed up causing this file to
+ # appear out of date. Touch it so that we don't try to regenerate it.
+ touch ${S}/doc/xsltproc.1
+}
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+# older versions of this recipe had ${PN}-utils
+RPROVIDES_${PN}-bin += "${PN}-utils"
+RCONFLICTS_${PN}-bin += "${PN}-utils"
+RREPLACES_${PN}-bin += "${PN}-utils"
+
+
+do_install_append_class-native () {
+ create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
+}
+
+FILES_${PN} += "${libdir}/libxslt-plugins"
+FILES_${PN}-dev += "${libdir}/xsltConf.sh"
+
+BBCLASSEXTEND = "native nativesdk"