aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/liburcu/files
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2013-10-31 08:17:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-08 17:30:52 +0000
commit4b2aa17a5c5d2ccf9824a4d2fd71f600b18ba2f2 (patch)
tree5cdf8726b6acc230bc2747fa1c512aa7fe2f1bc7 /meta/recipes-support/liburcu/files
parent60973d0584e2533f0debfcd8e80c5e29beb68e37 (diff)
downloadopenembedded-core-contrib-4b2aa17a5c5d2ccf9824a4d2fd71f600b18ba2f2.tar.gz
liburcu: upgrade to 0.8.0
Fix case where ${B} != ${S}; add patch to allow out of tree doc exemples build to work Add patch to remove CC=gcc when CC is defined, in order to use the cross compiler. Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/liburcu/files')
-rw-r--r--meta/recipes-support/liburcu/files/fixCCflag.patch20
-rw-r--r--meta/recipes-support/liburcu/files/fixsepbuild.patch19
2 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/liburcu/files/fixCCflag.patch b/meta/recipes-support/liburcu/files/fixCCflag.patch
new file mode 100644
index 0000000000..2e526d4517
--- /dev/null
+++ b/meta/recipes-support/liburcu/files/fixCCflag.patch
@@ -0,0 +1,20 @@
+Upstream-Status: Pending
+
+Use cross compiler for doc exemples too
+
+Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com>
+
+Index: userspace-rcu-0.8.0/doc/examples/Makefile.examples.template
+===================================================================
+--- userspace-rcu-0.8.0.orig/doc/examples/Makefile.examples.template 2013-08-30 21:25:20.000000000 +0300
++++ userspace-rcu-0.8.0/doc/examples/Makefile.examples.template 2013-10-23 13:34:30.405550556 +0300
+@@ -11,7 +11,9 @@
+ #
+ # This makefile is purposefully kept simple to support GNU and BSD make.
+
++ifndef CC
+ CC = gcc
++endif
+ CFLAGS = -g -O2 -Wall
+
+ all: $(BINARY)
diff --git a/meta/recipes-support/liburcu/files/fixsepbuild.patch b/meta/recipes-support/liburcu/files/fixsepbuild.patch
new file mode 100644
index 0000000000..9cd0ab9e73
--- /dev/null
+++ b/meta/recipes-support/liburcu/files/fixsepbuild.patch
@@ -0,0 +1,19 @@
+Upstream-Status: Pending
+
+Fix out of tree build for doc examples
+
+Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com>
+
+Index: userspace-rcu-0.8.0/doc/examples/Makefile.am
+===================================================================
+--- userspace-rcu-0.8.0.orig/doc/examples/Makefile.am 2013-08-30 21:25:20.000000000 +0300
++++ userspace-rcu-0.8.0/doc/examples/Makefile.am 2013-10-21 17:52:34.774597179 +0300
+@@ -128,7 +128,7 @@
+ cp -fR $(srcdir)/$$subdir $(builddir); \
+ done; \
+ fi
+- $(MAKE) -f dist-files/Makefile AM_CPPFLAGS="$(CPPFLAGS) -I../../../urcu/ -I../../../" AM_CFLAGS='$(CFLAGS)' AM_LDFLAGS='$(LDFLAGS) -L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all
++ $(MAKE) -f dist-files/Makefile AM_CPPFLAGS="$(CPPFLAGS) -I$(top_srcdir) -I../../../urcu/ -I../../../" AM_CFLAGS='$(CFLAGS)' AM_LDFLAGS='$(LDFLAGS) -L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all
+
+ clean-local:
+ $(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean