summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libssh2/libssh2_1.10.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex@linutronix.de>2021-09-08 20:01:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-11 18:31:05 +0100
commit6547e565cc1685eb4e42f61d88203cf743a06284 (patch)
tree9e08f287cca240cef5829c03ca55807968bf7854 /meta/recipes-support/libssh2/libssh2_1.10.0.bb
parent81a101332e7e59848165b06b734056a385e8cc3f (diff)
downloadopenembedded-core-contrib-6547e565cc1685eb4e42f61d88203cf743a06284.tar.gz
libssh2: update 1.9.0 -> 1.10.0
0001-configure-Conditionally-undefine-backend-m4-macro.patch no longer needed; code removed upstream. License-Update: copyright years Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libssh2/libssh2_1.10.0.bb')
-rw-r--r--meta/recipes-support/libssh2/libssh2_1.10.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-support/libssh2/libssh2_1.10.0.bb b/meta/recipes-support/libssh2/libssh2_1.10.0.bb
new file mode 100644
index 0000000000..072d6819c0
--- /dev/null
+++ b/meta/recipes-support/libssh2/libssh2_1.10.0.bb
@@ -0,0 +1,50 @@
+SUMMARY = "A client-side C library implementing the SSH2 protocol"
+HOMEPAGE = "http://www.libssh2.org/"
+SECTION = "libs"
+
+DEPENDS = "zlib"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3e089ad0cf27edf1e7f261dfcd06acc7"
+
+SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
+ file://run-ptest \
+ "
+
+SRC_URI:append:ptest = " file://0001-Don-t-let-host-enviroment-to-decide-if-a-test-is-bui.patch"
+
+SRC_URI[sha256sum] = "2d64e90f3ded394b91d3a2e774ca203a4179f69aebee03003e5a6fa621e41d51"
+
+inherit autotools pkgconfig ptest
+
+EXTRA_OECONF += "\
+ --with-libz \
+ --with-libz-prefix=${STAGING_LIBDIR} \
+ "
+
+# only one of openssl and gcrypt could be set
+PACKAGECONFIG ??= "openssl"
+PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
+PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
+
+BBCLASSEXTEND = "native nativesdk"
+
+# required for ptest on documentation
+RDEPENDS:${PN}-ptest = "man-db openssh util-linux-col"
+RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
+
+do_compile_ptest() {
+ sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
+ oe_runmake check
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
+ cp -rf ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/tests/ssh2.sh ${D}${PTEST_PATH}/tests/
+ cp -rf ${S}/tests/etc ${D}${PTEST_PATH}/tests/
+ mkdir -p ${D}${PTEST_PATH}/docs
+ cp -r ${S}/docs/* ${D}${PTEST_PATH}/docs/
+}