summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb
diff options
context:
space:
mode:
authorValentin Popa <valentin.popa@intel.com>2013-10-28 16:02:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-29 10:40:01 +0000
commit67a562d236735d1bb08e7c2f5ea01409f59741d3 (patch)
tree882195eca1d6d84effda7e8022c2e8b0fc38812c /meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb
parentdb0af1b3ca6b4de61dbcb8b264e418fe40c36fae (diff)
downloadopenembedded-core-contrib-67a562d236735d1bb08e7c2f5ea01409f59741d3.tar.gz
libsoup: upgrade to 2.44.1
Tested with midori-browser on qemux86 and qemuarm. Signed-off-by: Valentin Popa <valentin.popa@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb
new file mode 100644
index 0000000000..6c3c1db269
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.44.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "An HTTP library implementation in C"
+HOMEPAGE = "http://www.gnome.org/"
+BUGTRACKER = "https://bugzilla.gnome.org/"
+
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SECTION = "x11/gnome/libs"
+
+DEPENDS = "glib-2.0 gnutls libxml2 libproxy sqlite3"
+
+# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Enable
+# by default but let it be easily disabled.
+PACKAGECONFIG ??= "gnome"
+PACKAGECONFIG[gnome] = "--with-gnome,--without-gnome"
+
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "c8e3b59b16e8fbad430f47adb3bbd3df"
+SRC_URI[sha256sum] = "c532c331dd5f7eb78438867302ed6897a847c82b287ed9347bea8d1937974c1d"
+
+S = "${WORKDIR}/libsoup-${PV}"
+
+inherit autotools pkgconfig
+
+# glib-networking is needed for SSL, proxies, etc.
+RRECOMMENDS_${PN} = "glib-networking"