aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-08-19 14:56:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-23 18:23:13 -0700
commit039b1a04db32bed23536a23983c3b6d91e1166c7 (patch)
treea9279b417e4f19ad46734030cd17c58489bc8394 /meta/recipes-support/libpcre
parent4e108857e0d40105f7ecbc55e99bd6c367bb7386 (diff)
downloadopenembedded-core-contrib-039b1a04db32bed23536a23983c3b6d91e1166c7.tar.gz
libpcre: the generated libtool uses HOST_SYS
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'meta/recipes-support/libpcre')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.12.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.12.bb b/meta/recipes-support/libpcre/libpcre_8.12.bb
index 2972c1a51f..54d1f98406 100644
--- a/meta/recipes-support/libpcre/libpcre_8.12.bb
+++ b/meta/recipes-support/libpcre/libpcre_8.12.bb
@@ -30,11 +30,11 @@ EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10
do_compile () {
# stop libtool from trying to link with host libraries - fix from #33
# this resolve build problem on amd64 - #1015
- if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
- sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
+ if [ -e ${S}/${HOST_SYS}-libtool ] ; then
+ sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
else
- ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool
- sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
+ ln -sf ${S}/libtool ${S}/${HOST_SYS}-libtool
+ sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
fi
# The generation of dftables can lead to timestamp problems with ccache