aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/liboil
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@hale.at>2011-09-15 10:23:58 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 23:09:26 +0100
commitf7f129b60d33e2758a3a9cc66a98251e1325664d (patch)
tree89b92cb8bafa3b35465f63bf5490a5156dba084a /meta/recipes-support/liboil
parent125eb103194de5788920df13ccbc8004c54fb217 (diff)
downloadopenembedded-core-contrib-f7f129b60d33e2758a3a9cc66a98251e1325664d.tar.gz
liboil-0.3.17: add upstream Fix-enable-vfp-flag patch
Add upstream 1921498bcc06408e8b051a3a9e9ce4182998f748 patch to fix compiling with vfp Without this patch this error occours on arm with vfp and softfloat: | math_vfp_asm.S:273: Error: selected processor does not support `fnegd d12,d4' | math_vfp_asm.S:273: Error: selected processor does not support `fstmiad r0!,{d12,d13,d14,d15}' | math_vfp_asm.S:273: Error: selected processor does not support `fmxr fpscr,lr' | make[3]: *** [math_vfp_asm.lo] Error 1 Signed-off-by: Bernhard Guillon <Bernhard.Guillon@hale.at> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/liboil')
-rw-r--r--meta/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch39
-rw-r--r--meta/recipes-support/liboil/liboil_0.3.17.bb3
2 files changed, 41 insertions, 1 deletions
diff --git a/meta/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch b/meta/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch
new file mode 100644
index 0000000000..5b7dd4e7f1
--- /dev/null
+++ b/meta/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch
@@ -0,0 +1,39 @@
+From 1921498bcc06408e8b051a3a9e9ce4182998f748 Mon Sep 17 00:00:00 2001
+From: David Schleef <ds@schleef.org>
+Date: Fri, 8 Apr 2011 10:05:49 -0700
+Subject: [PATCH 10/10] Fix --enable-vfp flag
+
+Patch from Christophe Lyon, fixes #36084.
+---
+ configure.ac | 4 ++--
+ liboil/arm/Makefile.am | 1 +
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 98c81fb..407d88c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -188,8 +188,8 @@ fi
+ AC_ARG_ENABLE(vfp,
+ AC_HELP_STRING([--enable-vfp],[compile with Vector Floating-point unit support]),
+ enable_vfp=$enableval,enable_vfp=yes)
+-if test "x$enable-vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
+- AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
++if test "x$enable_vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
++ AS_COMPILER_FLAG(["-mfpu=vfp"],
+ [VFP_CFLAGS="$VFP_CFLAGS -mfpu=vfp"],
+ true)
+ #AS_COMPILER_FLAG(["-Wa,-mfloat-abi=softfp"],
+diff --git a/liboil/arm/Makefile.am b/liboil/arm/Makefile.am
+index ead08ed..cd8d9fa 100644
+--- a/liboil/arm/Makefile.am
++++ b/liboil/arm/Makefile.am
+@@ -6,4 +6,5 @@ libarm_la_SOURCES = \
+ math_vfp_asm.S
+
+ libarm_la_CFLAGS = $(LIBOIL_CFLAGS) $(VFP_CFLAGS)
++libarm_la_CCASFLAGS = $(LIBOIL_CFLAGS) $(VFP_CFLAGS)
+
+--
+1.7.6
+
diff --git a/meta/recipes-support/liboil/liboil_0.3.17.bb b/meta/recipes-support/liboil/liboil_0.3.17.bb
index 64e1ddd2f9..10a845e42f 100644
--- a/meta/recipes-support/liboil/liboil_0.3.17.bb
+++ b/meta/recipes-support/liboil/liboil_0.3.17.bb
@@ -10,11 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ad80780d9c5205d63481a0184e199a15 \
file://testsuite/trans.c;endline=29;md5=380ecd43121fe3dcc0d8d7e5984f283d"
DEPENDS = "glib-2.0"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://liboil.freedesktop.org/download/${BPN}-${PV}.tar.gz \
file://no-tests.patch \
file://fix-unaligned-whitelist.patch \
+ file://0001-Fix-enable-vfp-flag.patch \
"
SRC_URI[md5sum] = "47dc734f82faeb2964d97771cfd2e701"