summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl
diff options
context:
space:
mode:
authorMihai Prica <mihai.prica@intel.com>2012-12-04 18:50:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:30:36 +0000
commita343ced372ba659b3388a09ce615ee9a9127d921 (patch)
tree124045e230ecb26190350be940dd66f5e9c12a74 /meta/recipes-support/libnl/libnl
parenta3a0e29d5d796fdf6755503cc31e45199b79d756 (diff)
downloadopenembedded-core-contrib-a343ced372ba659b3388a09ce615ee9a9127d921.tar.gz
libnl: upgrade to 3.2.14
* Based on the 3.2.9 recipe from meta-oe * Modified the patches to work with the new name of the library file (libnl-3.so) Signed-off-by: Mihai Prica <mihai.prica@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/libnl/libnl')
-rw-r--r--meta/recipes-support/libnl/libnl/fix-pc-file.patch17
-rw-r--r--meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch36
2 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libnl/libnl/fix-pc-file.patch b/meta/recipes-support/libnl/libnl/fix-pc-file.patch
new file mode 100644
index 0000000000..fe8b833a1c
--- /dev/null
+++ b/meta/recipes-support/libnl/libnl/fix-pc-file.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Pending
+
+Some packages are asking only for libnl-2.0, but expects to get also
+libnl-genl, libnl-nf libnl-route, easiest way to fix them is here.
+
+Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
+Index: libnl-3.2.14/libnl-3.0.pc.in
+===================================================================
+--- libnl-3.2.14.orig/libnl-3.0.pc.in
++++ libnl-3.2.14/libnl-3.0.pc.in
+@@ -6,5 +6,5 @@ includedir=@includedir@
+ Name: libnl
+ Description: Convenience library for netlink sockets
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -lnl-@MAJ_VERSION@
++Libs: -L${libdir} -lnl-@MAJ_VERSION@ -lnl-genl-@MAJ_VERSION@ -lnl-nf-@MAJ_VERSION@ -lnl-route-@MAJ_VERSION@
+ Cflags: -I${includedir}/libnl@MAJ_VERSION@
diff --git a/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch b/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
new file mode 100644
index 0000000000..332ec0101d
--- /dev/null
+++ b/meta/recipes-support/libnl/libnl/fix-pktloc_syntax_h-race.patch
@@ -0,0 +1,36 @@
+Upstream-Status: Inappropriate [configuration]
+
+libnl has progressed to 0.3.2 and there does not appear to be any
+"make -j" issues with this build after my limited testing on that
+newer version so we can assume this issue is fixed upstream
+
+Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
+
+Index: libnl-3.2.14/lib/Makefile.am
+===================================================================
+--- libnl-3.2.14.orig/lib/Makefile.am
++++ libnl-3.2.14/lib/Makefile.am
+@@ -39,9 +39,12 @@ CLEANFILES = \
+
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
++route/pktloc.lo: route/pktloc_syntax.h route/pktloc_grammar.h
++route/pktloc_grammar.h: route/pktloc_grammar.c
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+ $(AM_V_GEN) $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
+
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+ $(AM_V_GEN) $(YACC) -d $(YFLAGS) -o $@ $^
+
+@@ -89,7 +92,9 @@ BUILT_SOURCES = \
+ route/cls/ematch_grammar.c \
+ route/cls/ematch_syntax.c \
+ route/pktloc_grammar.c \
+- route/pktloc_syntax.c
++ route/pktloc_syntax.c \
++ route/pktloc_syntax.h \
++ route/pktloc_grammar.h
+
+ EXTRA_DIST = \
+ route/pktloc_grammar.l \