summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-06-04 21:55:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-06 00:38:38 +0100
commit802091c09091b71814cbdce0ec3323741862f807 (patch)
tree29ae74299ff3067650dd25b827a5e5008536ae1d /meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
parent4115805fb4ff47fc794651ca59c858f91fe26fc7 (diff)
downloadopenembedded-core-contrib-802091c09091b71814cbdce0ec3323741862f807.tar.gz
libical: tidy up Perl finding
Instead of patching out the Perl detection, seed the search for perl with HOSTTOOLS_DIR/perl. This search usually fails because we don't let find_program() hunt in the system paths currently. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch')
-rw-r--r--meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch b/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
deleted file mode 100644
index b50f50e701..0000000000
--- a/meta/recipes-support/libical/libical/Remove-cmake-check-for-Perl.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 918cd8764a845a9d25918a444fbaa5070d2be609 Mon Sep 17 00:00:00 2001
-From: Jussi Kukkonen <jussi.kukkonen@intel.com>
-Date: Fri, 21 Aug 2015 16:38:05 +0300
-Subject: [PATCH] Remove cmake check for Perl
-
-We set "CMAKE_FIND_ROOT_PATH_MODE_PROGRAM ONLY" in cmake bbclass to
-make sure cmake does not find host programs. In this case we actually
-are fine with host perl: remove the check.
-
-Upstream-Status: Inappropriate [workaround]
-
-Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
----
- CMakeLists.txt | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-Index: libical-2.0.0/CMakeLists.txt
-===================================================================
---- libical-2.0.0.orig/CMakeLists.txt
-+++ libical-2.0.0/CMakeLists.txt
-@@ -116,8 +116,7 @@ if(SHARED_ONLY)
- set(LIBRARY_TYPE SHARED)
- endif()
-
--# must have Perl to create the derived stuff
--find_package(Perl REQUIRED)
-+set(PERL_EXECUTABLE perl)
-
- # Ensure finding 64bit libs when using 64-bit compilers
- if(CMAKE_CL_64)