summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcheck
diff options
context:
space:
mode:
authorPaulo Neves <ptsneves@gmail.com>2022-06-14 17:11:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-01 11:53:36 +0100
commit3ced538ef2b6d509bec5a619837382de574c710e (patch)
tree3bc5287ed2aa4cefb23d594890103bfcb81d27d0 /meta/recipes-support/libcheck
parent6edc1fffcbe1405d8c309a75643d7d6cd9a92848 (diff)
downloadopenembedded-core-contrib-3ced538ef2b6d509bec5a619837382de574c710e.tar.gz
libcheck: Fix too long shebang for native case.
It requires a shebang wrapper due to the fact that awk interpreter has an argument. Signed-off-by: Paulo Neves <ptsneves@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcheck')
-rw-r--r--meta/recipes-support/libcheck/libcheck_0.15.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/libcheck/libcheck_0.15.2.bb b/meta/recipes-support/libcheck/libcheck_0.15.2.bb
index 188d689cc3..1393aa2a1c 100644
--- a/meta/recipes-support/libcheck/libcheck_0.15.2.bb
+++ b/meta/recipes-support/libcheck/libcheck_0.15.2.bb
@@ -23,6 +23,9 @@ CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
RREPLACES:${PN} = "check (<= 0.9.5)"
+do_install:append:class-native() {
+ create_cmdline_shebang_wrapper ${D}${bindir}/checkmk
+}
BBCLASSEXTEND = "native nativesdk"
PACKAGES =+ "checkmk"