summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-08-27 21:16:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-27 21:41:44 +0100
commite883035f13ee86a63eaffe5ac55bf2ce20c5ba10 (patch)
tree4954a85fb19dff8a415789e273d53fb3128599e2 /meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb
parent437f827e98ca6b98c978ae736b7340f213d057f3 (diff)
downloadopenembedded-core-contrib-e883035f13ee86a63eaffe5ac55bf2ce20c5ba10.tar.gz
libcap-ng:upgrade 0.7.10 -> 0.7.11
0001-configure.ac-add-library-if-header-found.patch 0002-Wrap-pthread_atfork-usage-in-HAVE_PTHREAD_H.patch Removed since these are included in 0.7.11 Refresh the following patch: python.patch Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb
new file mode 100644
index 0000000000..43f76dc561
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.7.11.bb
@@ -0,0 +1,29 @@
+require libcap-ng.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/libcap-ng:"
+
+SUMMARY .= " - python"
+
+inherit lib_package autotools python3native
+
+DEPENDS += "libcap-ng python3 swig-native"
+
+S = "${WORKDIR}/libcap-ng-${PV}"
+
+EXTRA_OECONF += "--with-python --with-python3"
+EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
+
+do_install_append() {
+ rm -rf ${D}${bindir}
+ rm -rf ${D}${libdir}/.debug
+ rm -f ${D}${libdir}/lib*
+ rm -rf ${D}${libdir}/pkgconfig
+ rm -rf ${D}${datadir}
+ rm -rf ${D}${includedir}
+}
+
+# PACKAGES = "${PN}"
+
+FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
+FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
+