aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu/icu_58.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-28 15:34:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:08 +0000
commit3c01e48bb4ef53a1112993dd9cfe1aa66928c0d1 (patch)
tree78f6f1dbec82c3a1c89944d502c218b479c31a07 /meta/recipes-support/icu/icu_58.1.bb
parent685ef239df17c6aae8bf20529e3dacc32e18edb4 (diff)
downloadopenembedded-core-contrib-3c01e48bb4ef53a1112993dd9cfe1aa66928c0d1.tar.gz
icu: update to 58.1
The copyright for the software has been transferred to Unicode Inc from IBM, but the terms are same. libiculx and libicule are no longer produced as they depend on an external package icu-le-hb (previous versions had an option of using an internal implementation which now has been dropped). I have verified that icu dependencies in oe-core and meta-oe still build. (From OE-Core rev: 24c7ed595adf16e90816e2ef7f6417740deb688d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/icu/icu_58.1.bb')
-rw-r--r--meta/recipes-support/icu/icu_58.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/icu/icu_58.1.bb b/meta/recipes-support/icu/icu_58.1.bb
new file mode 100644
index 0000000000..cc7c94707b
--- /dev/null
+++ b/meta/recipes-support/icu/icu_58.1.bb
@@ -0,0 +1,28 @@
+require icu.inc
+
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=1b3b75c1777cd49ad5c6a24cd338cfc9"
+
+def icu_download_version(d):
+ pvsplit = d.getVar('PV', True).split('.')
+ return pvsplit[0] + "_" + pvsplit[1]
+
+ICU_PV = "${@icu_download_version(d)}"
+
+# http://errors.yoctoproject.org/Errors/Details/20486/
+ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
+
+BASE_SRC_URI = "http://download.icu-project.org/files/icu4c/${PV}/icu4c-${ICU_PV}-src.tgz"
+SRC_URI = "${BASE_SRC_URI} \
+ file://icu-pkgdata-large-cmd.patch \
+ file://fix-install-manx.patch \
+ "
+
+SRC_URI_append_class-target = "\
+ file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \
+ "
+SRC_URI[md5sum] = "1901302aaff1c1633ef81862663d2917"
+SRC_URI[sha256sum] = "0eb46ba3746a9c2092c8ad347a29b1a1b4941144772d13a88667a7b11ea30309"
+
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/"
+UPSTREAM_CHECK_URI = "http://download.icu-project.org/files/icu4c/"