aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/db/db_5.3.28.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-11-01 13:52:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-08 22:23:43 +0000
commit60aa20b8b691e5a72a6a11bf795b86c6359db886 (patch)
tree95cf195d174c2afe21b16e3f2464bccfcea86793 /meta/recipes-support/db/db_5.3.28.bb
parent090eeccce74554bd4282b6a0407963037bc761a9 (diff)
downloadopenembedded-core-contrib-60aa20b8b691e5a72a6a11bf795b86c6359db886.tar.gz
db: change types to avoid headers changing between architectures
Triggered by looking at why Python doesn't find db.h (because it greps db.h for a regex, and db.h is actually a oe_multilib_header wrapper) I realised that the only reason we have to oe_multilib_header db.h is because one typedef is different between 32-bit and 64-bit architectures. However, the typedef is for a 64-bit integer so instead of using long (64-bit) or long long (32-bit), just use int64_t. Some of the overly complicated configure tests need to be deleted after this change but that is safe as we're building in a controlled environment and can assume int64_t exists. With this done the header doesn't change between architectures, and it doesn't need to be wrapped by oe_multilib_header. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/db/db_5.3.28.bb')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
index 66282600f5..fb4befbaf7 100644
--- a/meta/recipes-support/db/db_5.3.28.bb
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -23,6 +23,7 @@ SRC_URI += "file://arm-thumb-mutex_db5.patch \
file://fix-parallel-build.patch \
file://0001-atomic-Rename-local-__atomic_compare_exchange-to-avo.patch \
file://0001-configure-Add-explicit-tag-options-to-libtool-invoca.patch \
+ file://sequence-type.patch \
"
# We are not interested in official latest 6.x versions;
# let's track what debian is using.
@@ -34,7 +35,7 @@ SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe7247804317
LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955"
-inherit autotools multilib_header
+inherit autotools
# Put virtual/db in any appropriate provider of a
# relational database, use it as a dependency in
@@ -112,8 +113,6 @@ do_install_append() {
ln -s db51/db.h ${D}/${includedir}/db.h
ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h
- oe_multilib_header db51/db.h
-
# The docs end up in /usr/docs - not right.
if test -d "${D}/${prefix}/docs"
then