aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-19 14:40:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-21 10:20:22 +0000
commitc4d3f5596662d6aced46f270f566b510a36e4952 (patch)
tree6e9b232c105ea36405e3d80d0c1db60d4091a7c1 /meta/recipes-support/boost
parent8e5ffa370c4259f925a0454fe7fd81c80ef2174b (diff)
downloadopenembedded-core-contrib-c4d3f5596662d6aced46f270f566b510a36e4952.tar.gz
boost: Upgrade 1.51 -> 1.52
Drop hash_enums.patch which is already applied upstream Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost')
-rw-r--r--meta/recipes-support/boost/boost.inc2
-rw-r--r--meta/recipes-support/boost/boost_1.51.0.bb11
-rw-r--r--meta/recipes-support/boost/boost_1.52.0.bb9
-rw-r--r--meta/recipes-support/boost/files/hash_enums.patch45
4 files changed, 9 insertions, 58 deletions
diff --git a/meta/recipes-support/boost/boost.inc b/meta/recipes-support/boost/boost.inc
index 4fe5a354de..1266666e30 100644
--- a/meta/recipes-support/boost/boost.inc
+++ b/meta/recipes-support/boost/boost.inc
@@ -16,8 +16,6 @@ BOOST_VER = "${@"_".join(d.getVar("PV",1).split("."))}"
BOOST_MAJ = "${@"_".join(d.getVar("PV",1).split(".")[0:2])}"
BOOST_P = "boost_${BOOST_VER}"
-INC_PR = "r5"
-
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BOOST_P}.tar.bz2"
S = "${WORKDIR}/${BOOST_P}"
diff --git a/meta/recipes-support/boost/boost_1.51.0.bb b/meta/recipes-support/boost/boost_1.51.0.bb
deleted file mode 100644
index b95049f277..0000000000
--- a/meta/recipes-support/boost/boost_1.51.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-include boost.inc
-
-LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
-
-PR = "${INC_PR}.1"
-
-SRC_URI += "file://arm-intrinsics.patch \
- file://hash_enums.patch \
- "
-SRC_URI[md5sum] = "4b6bd483b692fd138aef84ed2c8eb679"
-SRC_URI[sha256sum] = "fb2d2335a29ee7fe040a197292bfce982af84a645c81688a915c84c925b69696"
diff --git a/meta/recipes-support/boost/boost_1.52.0.bb b/meta/recipes-support/boost/boost_1.52.0.bb
new file mode 100644
index 0000000000..6c9dd3fafd
--- /dev/null
+++ b/meta/recipes-support/boost/boost_1.52.0.bb
@@ -0,0 +1,9 @@
+include boost.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI += "file://arm-intrinsics.patch \
+ "
+SRC_URI[md5sum] = "3a855e0f919107e0ca4de4d84ad3f750"
+SRC_URI[sha256sum] = "222b6afd7723f396f5682c20130314a10196d3999feab5ba920d2a6bf53bac92"
+
diff --git a/meta/recipes-support/boost/files/hash_enums.patch b/meta/recipes-support/boost/files/hash_enums.patch
deleted file mode 100644
index 368da962c1..0000000000
--- a/meta/recipes-support/boost/files/hash_enums.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Allow hashing of enums.
-Fixes errors like
-
-/opt/poky/1.3.0-1/sysroots/i586-poky-linux/usr/include/boost/functional/hash/extensions.hpp:257:34: error: no matching function for call to 'hash_value(const myspace::idx&)'
-
-Upstream-Status: Pending
-Singed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Index: boost_1_51_0/boost/functional/hash/hash.hpp
-===================================================================
---- boost_1_51_0.orig/boost/functional/hash/hash.hpp 2012-07-15 16:28:30.000000000 -0700
-+++ boost_1_51_0/boost/functional/hash/hash.hpp 2012-09-26 14:00:57.738364002 -0700
-@@ -15,6 +15,8 @@
- #include <boost/functional/hash/detail/hash_float.hpp>
- #include <string>
- #include <boost/limits.hpp>
-+#include <boost/type_traits/is_enum.hpp>
-+#include <boost/utility/enable_if.hpp>
-
- #if defined(BOOST_NO_TEMPLATE_PARTIAL_SPECIALIZATION)
- #include <boost/type_traits/is_pointer.hpp>
-@@ -89,6 +91,9 @@
- typename boost::hash_detail::long_numbers<T>::type hash_value(T);
- template <typename T>
- typename boost::hash_detail::ulong_numbers<T>::type hash_value(T);
-+ template <typename T>
-+ typename boost::enable_if<boost::is_enum<T>, std::size_t>::type
-+ hash_value(T);
-
- #if !BOOST_WORKAROUND(__DMC__, <= 0x848)
- template <class T> std::size_t hash_value(T* const&);
-@@ -178,7 +183,12 @@
- {
- return hash_detail::hash_value_unsigned(v);
- }
--
-+ template <typename T>
-+ typename boost::enable_if<boost::is_enum<T>, std::size_t>::type
-+ hash_value(T v)
-+ {
-+ return static_cast<std::size_t>(v);
-+ }
- // Implementation by Alberto Barbati and Dave Harris.
- #if !BOOST_WORKAROUND(__DMC__, <= 0x848)
- template <class T> std::size_t hash_value(T* const& v)