aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.69.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2018-12-18 17:30:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-03 12:35:06 +0000
commit894d2867275e72caac9181ea3b859d7595268f7f (patch)
treeee967b8aec8bbd903605dd1fc9e9b542c0cd6e14 /meta/recipes-support/boost/bjam-native_1.69.0.bb
parent2f34de99030ebf872e442cdbdb99f07617d8d45a (diff)
downloadopenembedded-core-contrib-894d2867275e72caac9181ea3b859d7595268f7f.tar.gz
boost: update to 1.69.0
Drop upstreamed reproducibility-add-file-directive-to-assembler.patch Drop signals library as upstream has removed it: https://www.boost.org/users/history/version_1_69_0.html Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.69.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.69.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.69.0.bb b/meta/recipes-support/boost/bjam-native_1.69.0.bb
new file mode 100644
index 0000000000..94f96e62d8
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.69.0.bb
@@ -0,0 +1,19 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch \
+"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}