aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.65.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-10-04 18:23:41 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-09 12:33:09 +0000
commitba2d391d8268203895ab2f792f92b7fd92deeb45 (patch)
tree4c3999fe31dc8afd335f9218c2709f92ec50108c /meta/recipes-support/boost/bjam-native_1.65.1.bb
parent234d9aaffc2b08846281247e5ba37b20fea1493d (diff)
downloadopenembedded-core-contrib-ba2d391d8268203895ab2f792f92b7fd92deeb45.tar.gz
boost: update to 1.65.1
Add a patch to fix bjam-native compile error (due to mistyped variable name). Drop upstreamed patch. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.65.1.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.65.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.65.1.bb b/meta/recipes-support/boost/bjam-native_1.65.1.bb
new file mode 100644
index 0000000000..92c86a3ef5
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.65.1.bb
@@ -0,0 +1,19 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch \
+ file://0001-Fix-a-strange-assert-typo-how-was-this-released-with.patch"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}