aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.60.0.bb
diff options
context:
space:
mode:
authorLukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>2016-01-06 18:31:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-11 23:23:16 +0000
commit17d77db5e1203e18cdd178e7d9a457310425ebdc (patch)
tree85cf492ed707b8cdea92dcc3c7ac9cdc2ee7e865 /meta/recipes-support/boost/bjam-native_1.60.0.bb
parentbe6070e54f8fe3b530dce66623287403a50ac8a1 (diff)
downloadopenembedded-core-contrib-17d77db5e1203e18cdd178e7d9a457310425ebdc.tar.gz
boost: update to 1.60.0
Due to the version update to 1.59.0, the two patches previously backported in this recipe are now dropped. The actual status of the arm-intrinsics.patch (reported with Upstream-Status: Backport) is unknown to the committer, and hence, that patch is kept in the recipe, even if it is possibly not required anymore. A deeper analysis is required to determine need and status of that patch. Second, boost 1.59.0 provides a new library, called timer, which is packaged as further library in the boost recipe. The update to boost 1.60.0 required no further changes beyond changing the checksum hashes. Third, on PPC architectures, qemuppc & mpc8315e-rdb [1] (tested by Ross Burton), the boost test library with the vanilla version 1.60.0 fails with: | gcc.compile.c++ bin.v2/libs/test/build/aca09349fdb84d131321425f6c3a38ed/execution_monitor.o | In file included from [...]/tmp/sysroots/mpc8315e-rdb/usr/include/fenv.h:114:0, | from [...]/tmp/sysroots/mpc8315e-rdb/usr/include/c++/5.3.0/fenv.h:36, | from ./boost/detail/fenv.hpp:97, | from ./boost/test/execution_monitor.hpp:64, | from ./boost/test/impl/execution_monitor.ipp:31, | from libs/test/src/execution_monitor.cpp:16: | ./boost/test/impl/execution_monitor.ipp: In function 'unsigned int boost::fpe::enable(unsigned int)': | ./boost/test/impl/execution_monitor.ipp:1383:7: error: expected id-expression before '(' token | ::feclearexcept(BOOST_FPE_ALL); | ^ | ./boost/test/impl/execution_monitor.ipp: In function 'unsigned int boost::fpe::disable(unsigned int)': | ./boost/test/impl/execution_monitor.ipp:1420:7: error: expected id-expression before '(' token | ::feclearexcept(BOOST_FPE_ALL); | ^ The commit f50e7bc9fed323c5705c0ed992c03e80eeec1dd6 from the boostorg/test github repository (branch: develop) [2] addresses that issue, but it was not merged in the 1.60.0 release. This commit adds this upstream-accepted patch, which was created by: `git checkout f50e7bc9fed323c5705c0ed992c03e80eeec1dd6 && git format-patch -1` [1] http://lists.openembedded.org/pipermail/openembedded-core/2016-January/114844.html [2] https://github.com/boostorg/test/commit/f50e7bc9fed323c5705c0ed992c03e80eeec1dd6 Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.60.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.60.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.60.0.bb b/meta/recipes-support/boost/bjam-native_1.60.0.bb
new file mode 100644
index 0000000000..32646d707b
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.60.0.bb
@@ -0,0 +1,18 @@
+include boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}