aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.58.0.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-08-04 10:33:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-12 22:47:12 +0100
commite7147de9f28925b1bb5df39d9c0848dd7957328c (patch)
tree08c7358c2680dc4151bbb550924217bda397b61f /meta/recipes-support/boost/bjam-native_1.58.0.bb
parente01b450a419aba2164a86510ca1ae402ec86aff0 (diff)
downloadopenembedded-core-contrib-e7147de9f28925b1bb5df39d9c0848dd7957328c.tar.gz
bjam-native: build and install bjam.debug
bjam is stripped by default, this causes QA warning while stripping it from do_populate_sysroot(): WARNING: File '.../tmp/sysroots/x86_64-linux/usr/bin/bjam' \ from bjam-native was already stripped, \ this will prevent future debugging! The JAM scripts allow to build unstripped version with '--debug'. Just build and install the bjam.debug to stop bjam from being stripped in compile step. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.58.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.58.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.58.0.bb b/meta/recipes-support/boost/bjam-native_1.58.0.bb
index d85d1a96cb..32646d707b 100644
--- a/meta/recipes-support/boost/bjam-native_1.58.0.bb
+++ b/meta/recipes-support/boost/bjam-native_1.58.0.bb
@@ -5,11 +5,14 @@ SECTION = "devel"
inherit native
+SRC_URI += "file://bjam-native-build-bjam.debug.patch"
+
do_compile() {
./bootstrap.sh --with-toolset=gcc
}
do_install() {
install -d ${D}${bindir}/
- install -c -m 755 bjam ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
}