summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bmap-tools/bmap-tools_git.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-22 11:16:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-25 15:06:46 +0000
commit7aea6a938544582d036c454beeef947c986eedc7 (patch)
treee72962ab9399ab4c8a93f41345816034111bd65b /meta/recipes-support/bmap-tools/bmap-tools_git.bb
parent44263ae8eb56966407cd8ca2c862daab342196f2 (diff)
downloadopenembedded-core-contrib-7aea6a938544582d036c454beeef947c986eedc7.tar.gz
bmap-tools: set PIP_INSTALL_PACKAGE, BASEVER
Change filename to _git.bb and use BASEVER to set PV. The wheel built by bdist_wheel is named "bmap_tool-*.whl" set the PIP_INSTALL_PACKAGE name accordingly. Use BASEVER to set PYPA_WHEEL to match the version in the wheel produced by bdist_wheel. [YOCTO #14638] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/bmap-tools/bmap-tools_git.bb')
-rw-r--r--meta/recipes-support/bmap-tools/bmap-tools_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/bmap-tools/bmap-tools_git.bb b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
new file mode 100644
index 0000000000..e3315321ed
--- /dev/null
+++ b/meta/recipes-support/bmap-tools/bmap-tools_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
+DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
+bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
+and copying files using the block map. The idea is that large file containing \
+unused blocks, like raw system image files, can be copied or flashed a lot \
+faster with bmaptool than with traditional tools like "dd" or "cp"."
+HOMEPAGE = "https://github.com/01org/bmap-tools"
+SECTION = "console/utils"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/intel/${BPN};branch=master;protocol=https"
+
+SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a"
+S = "${WORKDIR}/git"
+BASEVER = "3.6"
+PV = "${BASEVER}+git${SRCPV}"
+
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+
+# Need df from coreutils
+RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
+
+inherit python3native
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "bmap_tools"
+PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-${BASEVER}-*.whl"
+
+BBCLASSEXTEND = "native nativesdk"