aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/beecrypt/beecrypt
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-11-26 16:57:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-06 10:06:25 +0000
commitb0783ec2fd715a1a8a26e70d1829f2cf441b06cc (patch)
treec641a93a276f2933ac6526210aad23b23a2785d2 /meta/recipes-support/beecrypt/beecrypt
parent21fafc889e81411735de7d04ffe504e5cff4830d (diff)
downloadopenembedded-core-contrib-b0783ec2fd715a1a8a26e70d1829f2cf441b06cc.tar.gz
beecrypt: Update to 4.2.1
Rebased disable-icu-check.patch & fix-security.patch. Removed x64fix.patch as it is already in upstream. Also some configure changes: removing "--with-arch" as it can't cowork with expert mode, adding "--disable-openmp" to avoid unnecessary dependency. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-support/beecrypt/beecrypt')
-rw-r--r--meta/recipes-support/beecrypt/beecrypt/disable-icu-check.patch12
-rw-r--r--meta/recipes-support/beecrypt/beecrypt/fix-security.patch51
-rw-r--r--meta/recipes-support/beecrypt/beecrypt/x64fix.patch23
3 files changed, 32 insertions, 54 deletions
diff --git a/meta/recipes-support/beecrypt/beecrypt/disable-icu-check.patch b/meta/recipes-support/beecrypt/beecrypt/disable-icu-check.patch
index 3e18a87c3f..4a2f414778 100644
--- a/meta/recipes-support/beecrypt/beecrypt/disable-icu-check.patch
+++ b/meta/recipes-support/beecrypt/beecrypt/disable-icu-check.patch
@@ -2,11 +2,11 @@ We are unable to run code at configure time in a cross environemnt, but as we
control the build we can be fairly certain this dependency is met.
JL 05/07/10
-Index: beecrypt-4.1.2/configure.ac
+Index: beecrypt-4.2.1/configure.ac
===================================================================
---- beecrypt-4.1.2.orig/configure.ac 2004-12-21 11:37:56.000000000 +0000
-+++ beecrypt-4.1.2/configure.ac 2010-07-05 16:09:50.390083494 +0100
-@@ -243,32 +243,6 @@
+--- beecrypt-4.2.1.orig/configure.ac 2010-11-26 17:12:25.000000000 +0800
++++ beecrypt-4.2.1/configure.ac 2010-11-26 17:12:30.000000000 +0800
+@@ -292,32 +292,6 @@
# Predefines and checks for C++ API support
AH_TEMPLATE([CPPGLUE],[Define to 1 if you want to include the C++ code])
@@ -36,6 +36,6 @@ Index: beecrypt-4.1.2/configure.ac
- AC_LANG_POP(C)
-fi
-
+ AM_CONDITIONAL([WITH_CPLUSPLUS],[test "$ac_with_cplusplus" = yes])
+
if test "$ac_with_cplusplus" = yes ; then
- AC_DEFINE([CPPGLUE],1)
- fi
diff --git a/meta/recipes-support/beecrypt/beecrypt/fix-security.patch b/meta/recipes-support/beecrypt/beecrypt/fix-security.patch
index 6103562e0a..f28e393ca7 100644
--- a/meta/recipes-support/beecrypt/beecrypt/fix-security.patch
+++ b/meta/recipes-support/beecrypt/beecrypt/fix-security.patch
@@ -3,20 +3,38 @@ project:
http://www.mail-archive.com/fink-commits@lists.sourceforge.net/msg75742.html
JL 05/07/10
-Index: beecrypt-4.1.2/c++/security/Security.h
+Index: beecrypt-4.2.1/include/beecrypt/c++/beeyond/BeeCertificate.h
===================================================================
---- beecrypt-4.1.2.orig/c++/security/Security.h 2010-07-05 17:15:34.811273306 +0100
-+++ beecrypt-4.1.2/c++/security/Security.h 2010-07-05 17:15:38.696388531 +0100
-@@ -75,8 +75,6 @@
+--- beecrypt-4.2.1.orig/include/beecrypt/c++/beeyond/BeeCertificate.h 2010-11-26 17:22:57.000000000 +0800
++++ beecrypt-4.2.1/include/beecrypt/c++/beeyond/BeeCertificate.h 2010-11-26 17:23:01.000000000 +0800
+@@ -147,13 +147,13 @@
+ mutable bytearray* enc;
+
+ BeeCertificate();
+- BeeCertificate(InputStream& in) throw (IOException);
+
+ void encodeTBS(DataOutputStream& out) const throw (IOException);
+
+ bytearray* encodeTBS() const throw (CertificateEncodingException);
+
public:
- typedef vector<const Provider*> provider_vector;
- typedef provider_vector::iterator provider_vector_iterator;
--
++ BeeCertificate(InputStream& in) throw (IOException);
+ BeeCertificate(const BeeCertificate&) throw (CloneNotSupportedException);
+ virtual ~BeeCertificate();
+
+Index: beecrypt-4.2.1/include/beecrypt/c++/security/Security.h
+===================================================================
+--- beecrypt-4.2.1.orig/include/beecrypt/c++/security/Security.h 2010-11-26 17:20:55.000000000 +0800
++++ beecrypt-4.2.1/include/beecrypt/c++/security/Security.h 2010-11-26 17:21:36.000000000 +0800
+@@ -61,7 +61,6 @@
+ friend class SecureRandom;
+ friend class Signature;
+
- private:
struct spi
{
Object* cspi;
-@@ -91,6 +89,7 @@
+@@ -76,6 +75,7 @@
static spi* getSpi(const String& algo, const String& type, const Provider&) throw (NoSuchAlgorithmException);
static spi* getFirstSpi(const String& type);
@@ -24,20 +42,3 @@ Index: beecrypt-4.1.2/c++/security/Security.h
static const String& getKeyStoreDefault();
static bool _init;
-Index: beecrypt-4.1.2/c++/beeyond/BeeCertificate.h
-===================================================================
---- beecrypt-4.1.2.orig/c++/beeyond/BeeCertificate.h 2004-11-03 09:37:27.000000000 +0000
-+++ beecrypt-4.1.2/c++/beeyond/BeeCertificate.h 2010-07-05 17:16:25.216332324 +0100
-@@ -150,11 +150,11 @@
- mutable String* str;
-
- BeeCertificate();
-- BeeCertificate(InputStream& in) throw (IOException);
-
- bytearray* encodeTBS() const;
-
- public:
-+ BeeCertificate(InputStream& in) throw (IOException);
- BeeCertificate(const BeeCertificate&);
- virtual ~BeeCertificate();
-
diff --git a/meta/recipes-support/beecrypt/beecrypt/x64fix.patch b/meta/recipes-support/beecrypt/beecrypt/x64fix.patch
deleted file mode 100644
index ac02425d51..0000000000
--- a/meta/recipes-support/beecrypt/beecrypt/x64fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Don't have 64 appended to the libdir for 64bit platforms.
-
-JL 05/07/10
-Index: beecrypt-4.1.2/configure.ac
-===================================================================
---- beecrypt-4.1.2.orig/configure.ac 2010-07-05 16:39:43.000000000 +0100
-+++ beecrypt-4.1.2/configure.ac 2010-07-05 16:40:27.521082866 +0100
-@@ -585,15 +585,6 @@
-
- # Check where to install the libraries
- bc_libalt=
--case $target_os in
--linux*)
-- case $bc_target_arch in
-- powerpc64 | s390x | x86_64)
-- bc_libalt="64"
-- ;;
-- esac
-- ;;
--esac
- AC_SUBST(LIBALT,$bc_libalt)
-
- # Generate output files.