summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-02-02 04:06:11 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:39 +0000
commit29c4b19e640b544c9c351aec4292a3f65b619998 (patch)
treeca35a61b15ca547e038bc2cdf6e4188f2670fcc6 /meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch
parent3619d779205464175e3c08396660ff9ee52076f9 (diff)
downloadopenembedded-core-contrib-29c4b19e640b544c9c351aec4292a3f65b619998.tar.gz
apr: 1.6.2 -> 1.6.3
1. Improve inappropriate patches: - Drop inappropriate configure_fixes.patch Use setting variable ac_cv_file__dev_zero and ac_cv_sizeof_struct_iovec to replace - Drop cleanup.patch Aassign variable libtool at ./buildconf executing and use 0001-build-buildcheck.sh-improve-libtool-detection.patch to replace. Submitted it to upstream. - Rename configfix.patch to 0002-apr-Remove-workdir-path-references-from-installed-ap.patch Add its original comments and author, explain why it is inappropriate - Drop upgrade-and-fix-1.5.1.patch Use 0003-Makefile.in-configure.in-support-cross-compiling.patch to replace. And submitted it to upstream. 2. Fix build path issue to improve reproducibility Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch')
-rw-r--r--meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch b/meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch
new file mode 100644
index 0000000000..30fc07d4a0
--- /dev/null
+++ b/meta/recipes-support/apr/apr/0004-Fix-packet-discards-HTTP-redirect.patch
@@ -0,0 +1,39 @@
+From 7925eb1766a00ccee05c6e80b1d34f163a04b7b1 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Tue, 30 Jan 2018 09:43:34 +0800
+Subject: [PATCH 4/7] Fix packet discards HTTP redirect.
+
+Disconnect the connection by poll() timeout.
+If timeout=0 and apr_wait_for_io_or_timeout()=APR_TIMEUP then
+apr_socket_recv() returns EAGAIN.
+
+Upstream-Status: Pending
+
+Signed-off-by: Noriaki Yoshitane <yoshitane.nrs@cnt.ncos.nec.co.jp>
+Signed-off-by: Li Wang <li.wang@windriver.com>
+
+Rebase to 1.6.3
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ network_io/unix/sendrecv.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/network_io/unix/sendrecv.c b/network_io/unix/sendrecv.c
+index 4c0e0a6..1bdafba 100644
+--- a/network_io/unix/sendrecv.c
++++ b/network_io/unix/sendrecv.c
+@@ -85,6 +85,10 @@ apr_status_t apr_socket_recv(apr_socket_t *sock, char *buf, apr_size_t *len)
+ && (sock->timeout > 0)) {
+ do_select:
+ arv = apr_wait_for_io_or_timeout(NULL, sock, 1);
++ if ((arv == APR_TIMEUP) && (sock->timeout == 0)) {
++ *len = 0;
++ return EAGAIN;
++ }
+ if (arv != APR_SUCCESS) {
+ *len = 0;
+ return arv;
+--
+1.8.3.1
+