summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-09 08:16:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-12 16:39:27 +0100
commit08c06980648d3f72cddbf62a96d6915f5d54b94e (patch)
tree9d9401acd2f04be3275284a3fffdaf5f032fe573 /meta/recipes-sato
parent1d46d4c1150743a04ddf3d9936e431b487676043 (diff)
downloadopenembedded-core-contrib-08c06980648d3f72cddbf62a96d6915f5d54b94e.tar.gz
webkitgtk: Add missing header locale.h
This fixes build issues seen on mips, but problem is generic Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch19
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.36.0.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch b/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
new file mode 100644
index 0000000000..8f59db3130
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/add_missing_include.patch
@@ -0,0 +1,19 @@
+Include locale.h for LC_MESSAGE definition
+
+This fixes build error
+Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp:115:51: error: use of undeclared identifier 'LC_MESSAGES'
+ return g_variant_new_string(setlocale(LC_MESSAGES, nullptr));
+ ^
+Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=239030]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp
++++ b/Source/WebCore/accessibility/atspi/AccessibilityRootAtspi.cpp
+@@ -30,6 +30,7 @@
+ #include "FrameView.h"
+ #include "Page.h"
+ #include <glib/gi18n-lib.h>
++#include <locale.h>
+
+ namespace WebCore {
+
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
index 09d4493370..db8a565511 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.36.0.bb
@@ -15,6 +15,7 @@ SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://0001-Fix-build-without-opengl-or-es.patch \
file://reproducibility.patch \
file://0001-When-building-introspection-files-do-not-quote-CFLAG.patch \
+ file://add_missing_include.patch \
"
SRC_URI[sha256sum] = "b877cca1f105235f5dd57c7ac2b2c2be3c6b691ff444f93925c7254cf156c64d"