aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 14:22:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 12:04:27 +0100
commitd8419d30add74c73cfb038c7e611187a651c24e6 (patch)
tree0ee885007fba3b1e844ccea11b1d86e9924972c8 /meta/recipes-sato
parentd93ffea3164952954557a5a3dc90cebbd46272b2 (diff)
downloadopenembedded-core-contrib-d8419d30add74c73cfb038c7e611187a651c24e6.tar.gz
eds: Update to work with glib-2.0
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/eds/eds-dbus/depbuildfix.patch78
-rw-r--r--meta/recipes-sato/eds/eds-dbus_git.bb3
2 files changed, 80 insertions, 1 deletions
diff --git a/meta/recipes-sato/eds/eds-dbus/depbuildfix.patch b/meta/recipes-sato/eds/eds-dbus/depbuildfix.patch
new file mode 100644
index 0000000000..0785a9387a
--- /dev/null
+++ b/meta/recipes-sato/eds/eds-dbus/depbuildfix.patch
@@ -0,0 +1,78 @@
+G_CONST_RETURN is deprecated in glib 2.30 so remove to to avoid
+build failures. Also resolve other deprecation issues.
+
+RP 2011/10/12
+
+Upstream-Status: Pending
+
+Index: git/libedataserver/e-data-server-util.c
+===================================================================
+--- git.orig/libedataserver/e-data-server-util.c 2011-10-12 01:42:40.622045788 +0100
++++ git/libedataserver/e-data-server-util.c 2011-10-12 01:48:16.732045664 +0100
+@@ -165,7 +165,8 @@
+ static gunichar
+ stripped_char (gunichar ch)
+ {
+- gunichar *decomp, retval;
++ gunichar decomp[4];
++ gunichar retval;
+ GUnicodeType utype;
+ gsize dlen;
+
+@@ -175,7 +176,7 @@
+ case G_UNICODE_CONTROL:
+ case G_UNICODE_FORMAT:
+ case G_UNICODE_UNASSIGNED:
+- case G_UNICODE_COMBINING_MARK:
++ case G_UNICODE_SPACING_MARK:
+ /* Ignore those */
+ return 0;
+ break;
+@@ -183,7 +184,7 @@
+ /* Convert to lowercase, fall through */
+ ch = g_unichar_tolower (ch);
+ case G_UNICODE_LOWERCASE_LETTER:
+- if ((decomp = g_unicode_canonical_decomposition (ch, &dlen))) {
++ if ((dlen = g_unichar_fully_decompose (ch, FALSE, decomp, 4))) {
+ retval = decomp[0];
+ g_free (decomp);
+ return retval;
+Index: git/addressbook/libedata-book/e-data-book-factory.c
+===================================================================
+--- git.orig/addressbook/libedata-book/e-data-book-factory.c 2011-10-12 01:52:25.692045500 +0100
++++ git/addressbook/libedata-book/e-data-book-factory.c 2011-10-12 01:53:31.862045707 +0100
+@@ -238,7 +238,7 @@
+ return g_strdup_printf (
+ "/org/gnome/evolution/dataserver/addressbook/%d/%u",
+ getpid (),
+- g_atomic_int_exchange_and_add (&counter, 1));
++ g_atomic_int_add (&counter, 1));
+ }
+
+ static void
+Index: git/addressbook/libedata-book/e-data-book.c
+===================================================================
+--- git.orig/addressbook/libedata-book/e-data-book.c 2011-10-12 01:54:40.752045465 +0100
++++ git/addressbook/libedata-book/e-data-book.c 2011-10-12 01:55:16.012045897 +0100
+@@ -553,7 +553,7 @@
+
+ return g_strdup_printf ("/org/gnome/evolution/dataserver/addressbook/BookView/%d/%d",
+ getpid (),
+- g_atomic_int_exchange_and_add ((int*)&counter, 1));
++ g_atomic_int_add ((int*)&counter, 1));
+ }
+
+ static void
+Index: git/calendar/libedata-cal/e-data-cal-factory.c
+===================================================================
+--- git.orig/calendar/libedata-cal/e-data-cal-factory.c 2011-10-12 01:57:56.612045081 +0100
++++ git/calendar/libedata-cal/e-data-cal-factory.c 2011-10-12 01:57:58.832045211 +0100
+@@ -227,7 +227,7 @@
+ return g_strdup_printf (
+ "/org/gnome/evolution/dataserver/calendar/%d/%u",
+ getpid (),
+- g_atomic_int_exchange_and_add (&counter, 1));
++ g_atomic_int_add (&counter, 1));
+ }
+
+ static void
diff --git a/meta/recipes-sato/eds/eds-dbus_git.bb b/meta/recipes-sato/eds/eds-dbus_git.bb
index 7fa8311062..94243534c6 100644
--- a/meta/recipes-sato/eds/eds-dbus_git.bb
+++ b/meta/recipes-sato/eds/eds-dbus_git.bb
@@ -12,7 +12,7 @@ DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libi
SRCREV = "7337d11aed576e7caaa12b4e881ad8d33668799f"
PV = "2.30+git${SRCPV}"
-PR = "r1"
+PR = "r3"
SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
file://oh-contact.patch;striplevel=0 \
@@ -20,6 +20,7 @@ SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
file://optional_imapx_provider.patch \
file://new-contact-fix.patch \
file://old-gdk-api.patch \
+ file://depbuildfix.patch \
file://iconv-detect.h"
S = "${WORKDIR}/git"