aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2018-08-31 23:02:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-05 17:48:23 +0100
commitb77193ca8fd362d7b711574aa0b6eb07f7cc605f (patch)
tree967c06dd4e97eb6c47213596b0c52427061e5d44 /meta/recipes-sato
parentc2829b74892633c554a5f8262d4cafbe0fa6c3a7 (diff)
downloadopenembedded-core-contrib-b77193ca8fd362d7b711574aa0b6eb07f7cc605f.tar.gz
webkit: 2.20.3 -> 2.20.5
Upgrade webkitgtk from 2.20.3 to 2.20.5. * include fix of CVE-2018-12911 * backport patch for fix CVE-2017-17821 Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/0001-webkitgtk-fix-CVE-2017-17821.patch44
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.20.5.bb (renamed from meta/recipes-sato/webkit/webkitgtk_2.20.3.bb)5
2 files changed, 47 insertions, 2 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-webkitgtk-fix-CVE-2017-17821.patch b/meta/recipes-sato/webkit/webkitgtk/0001-webkitgtk-fix-CVE-2017-17821.patch
new file mode 100644
index 0000000000..a3f7599276
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/0001-webkitgtk-fix-CVE-2017-17821.patch
@@ -0,0 +1,44 @@
+Backport patch to fix CVE-2017-17821. Refer to
+https://security-tracker.debian.org/tracker/CVE-2017-17821.
+
+Upstream-Status: Backport [https://trac.webkit.org/changeset/232119/webkit]
+CVE: CVE-2017-17821
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+From 2a17b15297eb886b0bfb7d098ef607cfad6c3da0 Mon Sep 17 00:00:00 2001
+From: "mcatanzaro@igalia.com"
+ <mcatanzaro@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Wed, 23 May 2018 17:54:01 +0000
+Subject: [PATCH] Prohibit shrinking the FastBitVector
+ https://bugs.webkit.org/show_bug.cgi?id=181020
+
+Reviewed by Oliver Hunt.
+
+Prohibit shrinking the FastBitVector. It's not prepared for this and the current usage does
+not require it.
+
+* wtf/FastBitVector.cpp:
+(WTF::FastBitVectorWordOwner::resizeSlow):
+
+git-svn-id: http://svn.webkit.org/repository/webkit/trunk@232119 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ Source/WTF/wtf/FastBitVector.cpp | 2 ++
+ 2 files changed, 15 insertions(+)
+
+diff --git a/Source/WTF/wtf/FastBitVector.cpp b/Source/WTF/wtf/FastBitVector.cpp
+index eed316975f4..8b019aaa3ed 100644
+--- a/Source/WTF/wtf/FastBitVector.cpp
++++ b/Source/WTF/wtf/FastBitVector.cpp
+@@ -42,6 +42,8 @@ void FastBitVectorWordOwner::setEqualsSlow(const FastBitVectorWordOwner& other)
+ void FastBitVectorWordOwner::resizeSlow(size_t numBits)
+ {
+ size_t newLength = fastBitVectorArrayLength(numBits);
++
++ RELEASE_ASSERT(newLength >= arrayLength());
+
+ // Use fastCalloc instead of fastRealloc because we expect the common
+ // use case for this method to be initializing the size of the bitvector.
+--
+2.17.0
+
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.20.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.20.5.bb
index a528c5d891..c8d4f94f19 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.20.3.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.20.5.bb
@@ -22,10 +22,11 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://detect-gstreamer-gl.patch \
file://0012-soup-Forward-declare-URL-class.patch \
file://0001-Fix-PaintingData-has-no-member-named-lightVector-on-.patch \
+ file://0001-webkitgtk-fix-CVE-2017-17821.patch \
"
-SRC_URI[md5sum] = "efb69a0cc3cc67ef2647efec22e44c69"
-SRC_URI[sha256sum] = "579b307d78fa16a73f112790178022166d7ad17d4147492ced9b9fba48f20dd8"
+SRC_URI[md5sum] = "72a05f6a4dc1c78b079590a8fd280401"
+SRC_URI[sha256sum] = "15c0f8d26e9605afe0948d161ba5fd82efee8eda2debd409fd40a440ac3af990"
inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc