aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-08 18:57:59 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-13 22:47:31 +0000
commit908570a0da4bf755eb06fed817676c26351ab375 (patch)
treebffa3b2fcc300099a0e727aa4972ecb42adf5e30 /meta/recipes-sato
parentcf4d28d7d9820cc8f658670f766267d35133865f (diff)
downloadopenembedded-core-contrib-908570a0da4bf755eb06fed817676c26351ab375.tar.gz
puzzles: Upgrade and fix with clang
Delete upstreamed patches Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch48
-rw-r--r--meta/recipes-sato/puzzles/files/0001-rect-Fix-compiler-errors-about-uninitialized-use-of-.patch32
-rw-r--r--meta/recipes-sato/puzzles/puzzles_git.bb4
3 files changed, 50 insertions, 34 deletions
diff --git a/meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch b/meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch
new file mode 100644
index 0000000000..89aa1587c1
--- /dev/null
+++ b/meta/recipes-sato/puzzles/files/0001-Clarify-conditions-to-avoid-compiler-errors.patch
@@ -0,0 +1,48 @@
+From 72f2e9043ef509992dfa61791638db87bf0ae37b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 6 Dec 2016 01:20:00 +0000
+Subject: [PATCH] Clarify conditions to avoid compiler errors
+
+Fix errors pointed out by clang
+
+error: logical not is only applied to the left hand side of this bitwise operator [-Werror,-Wlogical-not-parentheses]
+| if (only_immutable && !copy->flags[i] & FLAG_IMMUTABLE) continue;
+| ^
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ signpost.c | 2 +-
+ tracks.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/signpost.c b/signpost.c
+index aa2e13a..2e2dff2 100644
+--- a/signpost.c
++++ b/signpost.c
+@@ -284,7 +284,7 @@ static int check_nums(game_state *orig, game_state *copy, int only_immutable)
+ int i, ret = 1;
+ assert(copy->n == orig->n);
+ for (i = 0; i < copy->n; i++) {
+- if (only_immutable && !copy->flags[i] & FLAG_IMMUTABLE) continue;
++ if (only_immutable && !(copy->flags[i] & FLAG_IMMUTABLE)) continue;
+ assert(copy->nums[i] >= 0);
+ assert(copy->nums[i] <= copy->n);
+ if (copy->nums[i] != orig->nums[i]) {
+diff --git a/tracks.c b/tracks.c
+index 5b27350..ca44ce1 100644
+--- a/tracks.c
++++ b/tracks.c
+@@ -1072,7 +1072,7 @@ static int solve_check_single_sub(game_state *state, int si, int id, int n,
+ x = i%w;
+ y = i/w;
+ if (abs(ox-x) > 1 || abs(oy-y) > 1) {
+- if (!state->sflags[i] & S_TRACK)
++ if (!(state->sflags[i] & S_TRACK))
+ did += solve_set_sflag(state, x, y, S_NOTRACK, what);
+ }
+ }
+--
+1.9.1
+
diff --git a/meta/recipes-sato/puzzles/files/0001-rect-Fix-compiler-errors-about-uninitialized-use-of-.patch b/meta/recipes-sato/puzzles/files/0001-rect-Fix-compiler-errors-about-uninitialized-use-of-.patch
deleted file mode 100644
index 0b971c432e..0000000000
--- a/meta/recipes-sato/puzzles/files/0001-rect-Fix-compiler-errors-about-uninitialized-use-of-.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 78d6d1706c21ad467520075ff7a8bf15cfbd68b3 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 30 Dec 2015 22:13:16 +0000
-Subject: [PATCH] rect: Fix compiler errors about uninitialized use of
- variables
-
-error: 'r2.x' may be used uninitialized in this function
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Submitted
-
- rect.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/rect.c b/rect.c
-index 55667c0..fa3a786 100644
---- a/rect.c
-+++ b/rect.c
-@@ -1317,7 +1317,8 @@ static char *new_game_desc(const game_params *params_in, random_state *rs,
- if (ndirs > 0) {
- int which, dir;
- struct rect r1, r2;
--
-+ memset(&r1, 0, sizeof(struct rect));
-+ memset(&r2, 0, sizeof(struct rect));
- which = random_upto(rs, ndirs);
- dir = dirs[which];
-
---
-2.6.4
-
diff --git a/meta/recipes-sato/puzzles/puzzles_git.bb b/meta/recipes-sato/puzzles/puzzles_git.bb
index 20b98891bb..a25c00760a 100644
--- a/meta/recipes-sato/puzzles/puzzles_git.bb
+++ b/meta/recipes-sato/puzzles/puzzles_git.bb
@@ -12,10 +12,10 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
file://fix-compiling-failure-with-option-g-O.patch \
file://0001-Use-labs-instead-of-abs.patch \
- file://0001-rect-Fix-compiler-errors-about-uninitialized-use-of-.patch \
file://0001-palisade-Fix-warnings-with-clang-on-arm.patch \
+ file://0001-Clarify-conditions-to-avoid-compiler-errors.patch \
"
-SRCREV = "346584bf6e38232be8773c24fd7dedcbd7b3d9ed"
+SRCREV = "8dfe5cec31e784e4ece2955ecc8cc35ee7e8fbb3"
PE = "1"
PV = "0.0+git${SRCPV}"