summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-26 21:58:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 12:37:53 +0000
commit40742b98cd25225e95029316539f66b1cbef8ef1 (patch)
treed1e630a8671a495b5c3d47e9cbb2fb14252f6e2a /meta/recipes-sato
parentb65e5280bf9e7f1f9c8e6acabab79bcf209e5342 (diff)
downloadopenembedded-core-contrib-40742b98cd25225e95029316539f66b1cbef8ef1.tar.gz
webkitgtk: Disable gold linker and JIT on riscv
both unsupported _yet_ on RISCV Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.28.4.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
index 8ebb3709a8..34b14f86ea 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.28.4.bb
@@ -94,6 +94,10 @@ EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
+# JIT and gold linker does not work on RISCV
+EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
+EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
+
# JIT not supported on MIPS either
EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "