summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-02-21 00:48:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-21 17:46:45 +0000
commit0d153e16ade03348f066e1cef916f28ce63b074c (patch)
tree9f65f30b2342201c3253425379b41c6a8480af0c /meta/recipes-sato
parentffa91ff19f73c3ed4060a6ecd3b6da7f46732cb3 (diff)
downloadopenembedded-core-contrib-0d153e16ade03348f066e1cef916f28ce63b074c.tar.gz
webkitgtk: fix reconfigure
| ln: failed to create symbolic link '/home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/webkitgtk/2.26.4-r0/recipe-sysroot-native/usr/bin/python': File exists Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.26.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.26.4.bb b/meta/recipes-sato/webkit/webkitgtk_2.26.4.bb
index 585723772e..fa109446d1 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.26.4.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.26.4.bb
@@ -61,7 +61,9 @@ PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
# webkitgtk is full of /usr/bin/env python, particular for generating docs
do_configure[postfuncs] += "setup_python_link"
setup_python_link() {
- ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
+ if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
+ ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
+ fi
}
EXTRA_OECMAKE = " \