aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-04-14 16:53:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 17:52:23 +0100
commit92436e402ac6222b625bbf99f6f23d39a58720fc (patch)
tree4a10570d89f57c04135af2aec92d1ffa98f2916c /meta/recipes-sato
parent5e6e2d9e53dae0d2637698abbefa8036dbdfe363 (diff)
downloadopenembedded-core-contrib-92436e402ac6222b625bbf99f6f23d39a58720fc.tar.gz
matchbox-keyboard: Enable GTK+3 IM module
* Build GTK+3 im module (and no GTK+2 by default) * Fix FILES for this case Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
index fb4c6e9166..c7870cf083 100644
--- a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
@@ -26,7 +26,7 @@ REQUIRED_DISTRO_FEATURES = "x11"
EXTRA_OECONF = "--disable-cairo"
-PACKAGECONFIG ??= "gtk2-im applet"
+PACKAGECONFIG ??= "gtk3-im applet"
PACKAGECONFIG[applet] = "--enable-applet,--disable-applet,matchbox-panel-2"
PACKAGECONFIG[gtk2-im] = "--enable-gtk-im,--disable-gtk-im,gtk+"
PACKAGECONFIG[gtk3-im] = "--enable-gtk3-im,--disable-gtk3-im,gtk+3"
@@ -39,7 +39,8 @@ FILES_${PN} = "${bindir}/ \
${datadir}/pixmaps \
${datadir}/matchbox-keyboard"
-FILES_${PN}-im = "${libdir}/gtk-2.0/*/immodules/*.so"
+FILES_${PN}-im = "${libdir}/gtk-2.0/*/immodules/*.so \
+ ${libdir}/gtk-3.0/*/immodules/*.so"
FILES_${PN}-applet = "${libdir}/matchbox-panel/*.so"
@@ -49,6 +50,7 @@ do_install_append () {
install -m 755 ${WORKDIR}/80matchboxkeyboard.sh ${D}/${sysconfdir}/X11/Xsession.d/
rm -f ${D}${libdir}/gtk-2.0/*/immodules/*.la
+ rm -f ${D}${libdir}/gtk-3.0/*/immodules/*.la
rm -f ${D}${libdir}/matchbox-panel/*.la
}