aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2012-03-27 15:01:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-27 13:23:11 +0100
commit674fa286d882ff94830cbf748e3f5abc63a5575a (patch)
tree723b8622c0302b3fa39c9b07f65dc4d3c34b13ed /meta/recipes-sato
parentd60b918186cadde05f2cde5b64d5b593ee0a6aba (diff)
downloadopenembedded-core-contrib-674fa286d882ff94830cbf748e3f5abc63a5575a.tar.gz
contacts.inc: conditionally install shema
Install schema should respect to GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL, If GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL is set, the schema should not be installed, but it always installed shema before, this was incorrect and it would cause host contamination since it would read $HOME/gconf/.gconf. [YOCTO #2178] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/pimlico/contacts.inc4
-rw-r--r--meta/recipes-sato/pimlico/contacts/contacts-conditionally-install-schema.patch37
2 files changed, 40 insertions, 1 deletions
diff --git a/meta/recipes-sato/pimlico/contacts.inc b/meta/recipes-sato/pimlico/contacts.inc
index 52c65ec128..e3921d86cd 100644
--- a/meta/recipes-sato/pimlico/contacts.inc
+++ b/meta/recipes-sato/pimlico/contacts.inc
@@ -27,6 +27,8 @@ FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
${datadir}/icons/hicolor"
SRC_URI = "file://stock_contact.png \
- file://stock_person.png"
+ file://stock_person.png \
+ file://contacts-conditionally-install-schema.patch \
+ "
SRC_URI_append_poky = " file://contacts-owl-window-menu.patch;apply=yes "
diff --git a/meta/recipes-sato/pimlico/contacts/contacts-conditionally-install-schema.patch b/meta/recipes-sato/pimlico/contacts/contacts-conditionally-install-schema.patch
new file mode 100644
index 0000000000..2ab7882c81
--- /dev/null
+++ b/meta/recipes-sato/pimlico/contacts/contacts-conditionally-install-schema.patch
@@ -0,0 +1,37 @@
+Install schema should respect to GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+If GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL is set, the schema should not
+be installed.
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+
+Upstream-Status: Pending
+---
+ data/Makefile.am | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/data/Makefile.am b/data/Makefile.am
+index f790823..b6fd643 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -14,13 +14,14 @@ dist_man1_MANS = contacts.1
+
+ if HAVE_GCONF
+ install-data-local:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
++ if [ "$(GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL)" != "1" ]; then \
++ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
+ $(GCONFTOOL) --makefile-install-rule $(schema_DATA) || \
+ (echo ;\
+ echo "*****************************************************"; \
+ echo "Installation of schemas failed, install them manually"; \
+- echo "*****************************************************";)
+- @true
++ echo "*****************************************************";); \
++ fi
+ endif
+
+ CLEANFILES = $(desktop_DATA)
+--
+1.7.7.6
+