summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-07-26 10:39:47 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:28 +0100
commit39b75d73aa5fce178c1577b0a5dfb8a694eff31d (patch)
treea3018c4ea15f024621ac1e98caf71d7357942a06 /meta/recipes-sato
parent9d556092fcc6f04c487afd126d52935bac133165 (diff)
downloadopenembedded-core-contrib-39b75d73aa5fce178c1577b0a5dfb8a694eff31d.tar.gz
webkitgtk: fix compile failure on beaglebone
Since the following patch applied in upstream webkitgtk ... commit 1a55d8c685b3e5b4dbeda202009e7527aa59eadd Author: simon.fraser@apple.com <simon.fraser@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc> Date: Thu Nov 23 22:20:09 2017 +0000 FELighting cleanup and optimization https://bugs.webkit.org/show_bug.cgi?id=179933 ... It missed to tweak `paintingData.lightVector' which caused PaintingData' has no member named 'lightVector' on ARM_NEON (beaglebone) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/0001-Fix-PaintingData-has-no-member-named-lightVector-on-.patch37
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.20.3.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/0001-Fix-PaintingData-has-no-member-named-lightVector-on-.patch b/meta/recipes-sato/webkit/webkitgtk/0001-Fix-PaintingData-has-no-member-named-lightVector-on-.patch
new file mode 100644
index 0000000000..25f4846592
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk/0001-Fix-PaintingData-has-no-member-named-lightVector-on-.patch
@@ -0,0 +1,37 @@
+From a5d4e038268ae23486fecc1966fd2e16a7f40ce8 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Wed, 25 Jul 2018 00:23:48 -0700
+Subject: [PATCH] Fix PaintingData' has no member named 'lightVector' on
+ ARM_NEON
+
+* platform/graphics/cpu/arm/filters/FELightingNEON.h:
+(WebCore::FELighting::platformApplyNeon):
+
+Upstream-Status: Submitted
+https://bugs.webkit.org/show_bug.cgi?id=187991
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h b/Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h
+index 42af922..b542a4c 100644
+--- a/Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h
++++ b/Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.h
+@@ -144,9 +144,9 @@ inline void FELighting::platformApplyNeon(const LightingData& data, const LightS
+ neonData.flags |= FLAG_CONE_EXPONENT_IS_1;
+ } else {
+ ASSERT(m_lightSource->type() == LS_DISTANT);
+- floatArguments.lightX = paintingData.lightVector.x();
+- floatArguments.lightY = paintingData.lightVector.y();
+- floatArguments.lightZ = paintingData.lightVector.z();
++ floatArguments.lightX = paintingData.initialLightingData.lightVector.x();
++ floatArguments.lightY = paintingData.initialLightingData.lightVector.y();
++ floatArguments.lightZ = paintingData.initialLightingData.lightVector.z();
+ floatArguments.padding2 = 1;
+ }
+
+--
+2.10.2
+
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.20.3.bb b/meta/recipes-sato/webkit/webkitgtk_2.20.3.bb
index 9d0f00a6d6..a528c5d891 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.20.3.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.20.3.bb
@@ -21,6 +21,7 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://0001-Fix-build-with-musl.patch \
file://detect-gstreamer-gl.patch \
file://0012-soup-Forward-declare-URL-class.patch \
+ file://0001-Fix-PaintingData-has-no-member-named-lightVector-on-.patch \
"
SRC_URI[md5sum] = "efb69a0cc3cc67ef2647efec22e44c69"