aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-11 17:34:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-12 22:31:59 +0000
commit81cfade0615ac1e52a4185b1dcaab7ad78a9e6fd (patch)
tree1cf4b6a07a026f5c06378c1cebfc0fc017d15422 /meta/recipes-sato
parent7603b15415301679bccbcb89af688c211704a43a (diff)
downloadopenembedded-core-contrib-81cfade0615ac1e52a4185b1dcaab7ad78a9e6fd.tar.gz
sato-icon-theme: simplify icon-name-mapping lookup
Patching an option into configure.ac and then running sed over path variables is fragile as the definition of $libexecdir can and has changed. Instead, tell configure to use our pkg-config-native wrapper when it uses pkg-config, and it will find the right binaries without any further munging. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme/iconpath-option.patch53
-rw-r--r--meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb7
2 files changed, 4 insertions, 56 deletions
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme/iconpath-option.patch b/meta/recipes-sato/sato-icon-theme/sato-icon-theme/iconpath-option.patch
deleted file mode 100644
index b392a932ae..0000000000
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme/iconpath-option.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-pkg-config will only search the target sysroot and we want the native script. This
-patch adds an option to allow the path to the tool to be specified.
-
-RP - 12/8/10
-
-Upstream-Status: Pending
-
-Index: sato-icon-theme-0.4.1/configure.ac
-===================================================================
---- sato-icon-theme-0.4.1.orig/configure.ac 2010-08-12 12:23:25.000000000 +0100
-+++ sato-icon-theme-0.4.1/configure.ac 2010-08-12 12:48:14.000000000 +0100
-@@ -11,20 +11,29 @@
-
- UTILS_REQUIRED=0.8.2
-
--AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
--PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
-- have_utils=yes, have_utils=no)
--if test "x$have_utils" = "xyes"; then
-- UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
-- ICONMAP="$UTILS_PATH/icon-name-mapping"
-- AC_SUBST(ICONMAP)
-- AC_MSG_RESULT([yes])
--else
-- AC_MSG_RESULT([no])
-- AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
-- and install sato-icon-theme])
-+PKG_PROG_PKG_CONFIG()
-+
-+AC_ARG_WITH(iconmap,
-+ AC_HELP_STRING([--with-iconmap=<dir>], [The location of the icon-name-mapping script to use]),
-+ ICONMAP=$withval, ICONMAP="")
-+
-+if test "x$ICONMAP" = "x"; then
-+ AC_MSG_CHECKING([icon-naming-utils >= $UTILS_REQUIRED])
-+ PKG_CHECK_EXISTS(icon-naming-utils >= $UTILS_REQUIRED,
-+ have_utils=yes, have_utils=no)
-+ if test "x$have_utils" = "xyes"; then
-+ UTILS_PATH="`$PKG_CONFIG --variable=program_path icon-naming-utils`"
-+ ICONMAP="$UTILS_PATH/icon-name-mapping"
-+
-+ AC_MSG_RESULT([yes])
-+ else
-+ AC_MSG_RESULT([no])
-+ AC_MSG_ERROR([icon-naming-utils >= $UTILS_REQUIRED is required to build
-+ and install sato-icon-theme])
-+ fi
- fi
-
-+AC_SUBST(ICONMAP)
-
- AC_CONFIG_FILES([
- Makefile
diff --git a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
index cf23aebf5e..a32e1a98e3 100644
--- a/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
+++ b/meta/recipes-sato/sato-icon-theme/sato-icon-theme_0.4.1.bb
@@ -11,7 +11,6 @@ PR = "r6"
DEPENDS = "icon-naming-utils-native libxml-simple-perl-native"
SRC_URI = "http://pokylinux.org/releases/sato/${BPN}-${PV}.tar.gz \
- file://iconpath-option.patch \
file://0001-Inherit-the-GNOME-icon-theme.patch"
SRC_URI[md5sum] = "86a847f3128a43a9cf23b7029a656f50"
@@ -19,9 +18,11 @@ SRC_URI[sha256sum] = "0b0a2807a6a96918ac799a86094ec3e8e2c892be0fd679a4232c2a77f2
inherit autotools pkgconfig allarch gtk-icon-cache perlnative
-FILES_${PN} += "${datadir}"
+# The configure script uses pkg-config to find native binaries to execute, so
+# tell it to use our pkg-config-native wrapper.
+export PKG_CONFIG = "pkg-config-native"
-EXTRA_OECONF += "--with-iconmap=${@d.getVar('STAGING_LIBEXECDIR_NATIVE', True).replace('sato-icon-theme', 'icon-naming-utils')}/icon-name-mapping"
+FILES_${PN} += "${datadir}/icons/Sato"
do_install_append() {
find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \;