aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2015-05-18 16:58:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-20 21:40:13 +0100
commitcae5c340e4c7af00a181d11346120b550ba83175 (patch)
tree4bfd5efb1c477fe3d608df7c73c795f11d0f08d7 /meta/recipes-sato/webkit
parent096b71a5c24378a449bc38063316555f02af8e18 (diff)
downloadopenembedded-core-contrib-cae5c340e4c7af00a181d11346120b550ba83175.tar.gz
webkitgtk: disable audio and video support
This allows removal of gstreamer 0.10 dependency from webkit recipe https://bugzilla.yoctoproject.org/show_bug.cgi?id=6294 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit')
-rw-r--r--meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb b/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
index 334870292e..b9a9d7a002 100644
--- a/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
+++ b/meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb
@@ -14,7 +14,7 @@ ICU_LIB = "icu"
ICU_LIB_powerpc = "pango"
DEPENDS = "zlib enchant libsoup-2.4 curl libxml2 cairo libxslt libxt libidn gnutls \
- gtk+ gstreamer gst-plugins-base flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
+ gtk+ flex-native gperf-native perl-native-runtime sqlite3 ${ICU_LIB}"
DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)}"
# The libxt requires x11 in DISTRO_FEATURES
@@ -42,6 +42,9 @@ inherit autotools lib_package gtk-doc pkgconfig distro_features_check
S = "${WORKDIR}/webkit-${PV}/"
+# Disabled by default because it pulls in obsolete gstreamer 0.10
+WEBKIT_AUDIOVIDEO ?= "--disable-video --disable-web-audio"
+
EXTRA_OECONF = "\
--enable-debug=no \
--enable-svg \
@@ -51,6 +54,7 @@ EXTRA_OECONF = "\
--enable-link-prefetch \
--with-gtk=2.0 \
--disable-geolocation \
+ ${WEBKIT_AUDIOVIDEO} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '--enable-webgl', '--disable-webgl', d)} \
UNICODE_CFLAGS=-D_REENTRANT \
"