aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-03-09 17:02:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-12 22:11:18 +0000
commitcfd1ccb615a1196f4501f8fea29060a9e0b599f5 (patch)
treea9acc4a8555c057aa96e342b90c499ce42d794ce /meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
parent1011ce60412b17e4a1d2293dabe76027547429f7 (diff)
downloadopenembedded-core-contrib-cfd1ccb615a1196f4501f8fea29060a9e0b599f5.tar.gz
webkitgtk: enable gobject introspection
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.10.7.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.10.7.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
index 8812967603..849a33a1e7 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.10.7.bb
@@ -15,11 +15,14 @@ SRC_URI = "\
file://clang.patch \
file://0001-Enable-backtrace-on-linux-when-using-glibc.patch \
file://0001-Fix-build-with-non-glibc-libraries-on-linux.patch \
+ file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
+ file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
+ file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \
"
SRC_URI[md5sum] = "84832b9d8329413b4f1d87df5f7e8efe"
SRC_URI[sha256sum] = "990d62c82ed6dede31a6ff0a82d847f16b812842ff3e1093d17113627652864e"
-inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even
+inherit cmake lib_package pkgconfig perlnative pythonnative distro_features_check upstream-version-is-even gobject-introspection
# depends on libxt
REQUIRED_DISTRO_FEATURES = "x11"
@@ -51,7 +54,7 @@ PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
EXTRA_OECMAKE = " \
-DPORT=GTK \
-DCMAKE_BUILD_TYPE=Release \
- -DENABLE_INTROSPECTION=OFF \
+ ${@bb.utils.contains('COMBINED_FEATURES', 'gobject-introspection-data', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
-DENABLE_GTKDOC=OFF \
-DENABLE_MINIBROWSER=ON \
"
@@ -76,3 +79,10 @@ FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbu
# http://errors.yoctoproject.org/Errors/Details/20370/
ARM_INSTRUCTION_SET = "arm"
+
+# Invalid data memory access: 0x00000000
+# ...
+# qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+# Segmentation fault
+EXTRA_OECMAKE_append_powerpc = " -DENABLE_INTROSPECTION=OFF "
+