aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/tasks/task-core.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-09-14 17:19:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:20:38 +0100
commit07407baafb728c5ae1bb283f5b02a2ac773360bc (patch)
treebb47ceee79b5600e68f8530c407c440c8360a6d1 /meta/recipes-sato/tasks/task-core.bb
parenteaef15630c38b8dd60f83df766e6b17cb3838130 (diff)
downloadopenembedded-core-contrib-07407baafb728c5ae1bb283f5b02a2ac773360bc.tar.gz
task-core: split into task-core-console and task-core-x11
[YOCTO #1481] Since tasks are referred to almost exclusively via RDEPENDS, and bitbake will build an entire task recipe when only one of its task packages are actually needed, building a console-only image that uses task-core-apps-console (or less directly, has apps-console in its IMAGE_FEATURES) will cause a build of a whole list of X11 applications that aren't needed. Splitting the task-core recipe into X11 and console portions prevents this issue. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/tasks/task-core.bb')
-rw-r--r--meta/recipes-sato/tasks/task-core.bb73
1 files changed, 0 insertions, 73 deletions
diff --git a/meta/recipes-sato/tasks/task-core.bb b/meta/recipes-sato/tasks/task-core.bb
deleted file mode 100644
index a595ad71ae..0000000000
--- a/meta/recipes-sato/tasks/task-core.bb
+++ /dev/null
@@ -1,73 +0,0 @@
-#
-# Copyright (C) 2007-2008 OpenedHand Ltd.
-#
-
-DESCRIPTION = "Tasks for OpenedHand Poky"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
- file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r34"
-
-PACKAGES = "\
- task-core-apps-console \
- task-core-apps-console-dbg \
- task-core-apps-console-dev \
- task-core-apps-x11-core \
- task-core-apps-x11-core-dbg \
- task-core-apps-x11-core-dev \
- task-core-apps-x11-games \
- task-core-apps-x11-games-dbg \
- task-core-apps-x11-games-dev \
- task-core-x11-base \
- task-core-x11-base-dbg \
- task-core-x11-base-dev \
- "
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-XSERVER ?= "xserver-kdrive-fbdev"
-
-ALLOW_EMPTY = "1"
-
-SPLASH ?= "psplash"
-
-# pcmanfm doesn't work on mips/powerpc
-FILEMANAGER ?= "pcmanfm"
-FILEMANAGER_mips ?= ""
-
-RDEPENDS_task-core-apps-console = "\
- avahi-daemon \
- dbus \
- portmap \
- ${SPLASH}"
-
-
-RDEPENDS_task-core-x11-base = "\
- dbus \
- pointercal \
- matchbox-wm \
- matchbox-keyboard \
- matchbox-keyboard-applet \
- matchbox-keyboard-im \
- matchbox-panel-2 \
- matchbox-desktop \
- matchbox-session \
- ${XSERVER} \
- x11-common \
- xserver-nodm-init \
- liberation-fonts \
- xauth \
- xhost \
- xset \
- xrandr"
-
-
-RDEPENDS_task-core-apps-x11-core = "\
- leafpad \
- ${FILEMANAGER} \
- matchbox-terminal \
- screenshot"
-
-
-RDEPENDS_task-core-apps-x11-games = "\
- oh-puzzles"