summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/settings-daemon
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-10 19:17:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:11 +0100
commit1722ce23075a00e111145cad6daa2ef87ba391fe (patch)
tree68aba0e232beca1f632d13b3ee798b48af9298c8 /meta/recipes-sato/settings-daemon
parent777080af697d35b3f983465d6a094f4171e57e56 (diff)
downloadopenembedded-core-contrib-1722ce23075a00e111145cad6daa2ef87ba391fe.tar.gz
libowl/settings-daemon/libnotify: add x11 to REQUIRED_DISTRO_FEATURES
The libowl, settings-daemon and libnotify requires gdk/gdkx.h which is provided by gtk when x11 in DISTRO_FEATURES, so add x11 to REQUIRED_DISTRO_FEATURES. The leafpad, settings-daemon and oh-puzzles requires libowl or settings-daemon, so add xx to REQUIRED_DISTRO_FEATURES for them too. The leafpad can't be built without libowl, so depends in directly rather than use DEPENDS_append_poky. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-sato/settings-daemon')
-rw-r--r--meta/recipes-sato/settings-daemon/settings-daemon_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-sato/settings-daemon/settings-daemon_git.bb b/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
index ba48d90773..c0615530af 100644
--- a/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
+++ b/meta/recipes-sato/settings-daemon/settings-daemon_git.bb
@@ -17,10 +17,13 @@ SRC_URI = "git://git.yoctoproject.org/xsettings-daemon \
S = "${WORKDIR}/git"
-inherit autotools pkgconfig gconf
+inherit autotools pkgconfig gconf distro_features_check
FILES_${PN} = "${bindir}/* ${sysconfdir}"
+# Requires gdk-x11-2.0 which is provided by gtk when x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"
+
do_install_append () {
install -d ${D}/${sysconfdir}/X11/Xsession.d
install -m 755 ${WORKDIR}/70settings-daemon.sh ${D}/${sysconfdir}/X11/Xsession.d/